Ask Your Question
0

Nvidia (propietary) driver kernel module insertion "not permitted"

asked 2019-03-03 17:02:41 -0600

I installed the nvidia drivers as per the rpmfusion instructions. On boot the nvidia-fallback.service unit starts nouveau because nvidia wont load. (thats all it tells me anywhere in the logs)

When i try to insert it manually the following happens:

$ sudo modprobe -vv nvidia
modprobe: INFO: custom logging function 0x55bf3f0e40b0 registered
insmod /lib/modules/4.20.13-200.fc29.x86_64/extra/nvidia/nvidia.ko 
modprobe: INFO: Failed to insert module '/lib/modules/4.20.13-200.fc29.x86_64/extra/nvidia/nvidia.ko': Operation not permitted
modprobe: ERROR: could not insert 'nvidia': Operation not permitted
modprobe: INFO: context 0x55bf40d38420 released

More details (output of nvidia-bug-report.sh) HERE if anyone cares.

System:

Dell XPS 15 9550
 - integrated intel graphics
 - GTX 960m dedicated graphics
Kernel:
 - version: 4.20.13-200.fc29.x86_64
 - cmdline: BOOT_IMAGE=/vmlinuz-4.20.13-200.fc29.x86_64 root=/dev/mapper/fedora-root ro resume=/dev/mapper/fedora-swap rd.lvm.lv=fedora/root rd.lvm.lv=fedora/swap rhgb quiet LANG=de_DE.UTF-8 rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1

Package versions:

$ dnf list --installed | grep nvidia
akmod-nvidia.x86_64                               3:418.43-1.fc29                        @rpmfusion-nonfree-updates
kmod-nvidia-4.20.13-200.fc29.x86_64.x86_64        3:418.43-1.fc29                        @@commandline             
nvidia-modprobe.x86_64                            3:418.43-1.fc29                        @rpmfusion-nonfree-updates
nvidia-persistenced.x86_64                        3:418.43-1.fc29                        @rpmfusion-nonfree-updates
nvidia-settings.x86_64                            3:418.43-1.fc29                        @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia.x86_64                        3:418.43-1.fc29                        @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-cuda.x86_64                   3:418.43-1.fc29                        @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-cuda-libs.x86_64              3:418.43-1.fc29                        @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-kmodsrc.x86_64                3:418.43-1.fc29                        @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-libs.x86_64                   3:418.43-1.fc29                        @rpmfusion-nonfree-updates
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-03-04 00:57:38 -0600

villykruse gravatar image

Could this be an issue?

Secure Boot

Secure Boot currently blocks the kernel from loading the NVIDIA driver. It must be disabled before booting the OS.

With secure boot enabled all kernel modules must be signed by Fedora, and obviously, Fedora could not sign anything they did not build.

edit flag offensive delete link more

Comments

Ok now i can modprobe nvidia at runtime.

For anyone with the same problem on the XPS 15:

  1. go into BIOS setup
  2. security - secure boot -> disabled
  3. boot order
    • make a new entry (the current one should use \EFI\fedora\shimx64.efi
    • new one should use \EFI\fedora\grub.64.efi directly

I personally have installed optimus as per this guide. and after i # systemctl mask nvidia-fallback.serviceed everything worked as expected.

Though performance is still worse than the iGPU on all optimus modes

g-frhun gravatar imageg-frhun ( 2019-03-04 06:01:26 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2019-03-03 17:00:03 -0600

Seen: 1,299 times

Last updated: Mar 04 '19