Ask Your Question
1

How could I fix the broken thunderbird

asked 2019-03-02 01:39:11 -0600

fedy88 gravatar image

Hello I have fedora 29 running. If I update thunderbird to the version 60.x I get always an error on start. I tried already many different command options. Always the same error. I tried also GNOME (I use KDE) - same error. The error output after start is (thunderbird:31645): Gtk-WARNING **: 08:07:36.311: Theme parsing error: <data>:1:34: Expected ')' in color definition

(thunderbird:31645): Gtk-WARNING **: 08:07:36.311: Theme parsing error: <data>:1:77: Expected ')' in color definition Segmentation fault (Speicherabzug geschrieben) BR Michael

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
2

answered 2019-03-02 16:23:56 -0600

ozeszty gravatar image

updated 2019-03-07 03:54:23 -0600

Hi, for now use one of workarounds from https://bugzilla.redhat.com/show_bug.... comments. There seem to be more than one issue, so not all suggestions work for everybody.

Firstly I modified Profiles.ini so that only one profile was there at the time.

Later I reverted it and created launchers for most used profiles: by adding new launchers, editing them and changing their commands to thunderbird --profile '~/.thunderbird/xxxxxxxxx.profile name' according to what's in ~/.thunderbird/ directory.

If you'll have to downgrade Thunderbird, do it using

dnf install https://kojipkgs.fedoraproject.org//packages/thunderbird/60.5.0/1.fc29/x86_64/thunderbird-60.5.0-1.fc29.x86_64.rpm

BUT it's really not the best option, since there were also some bugfixes since that version.

If you choose to make a downgrade, use versionlock to prevent Thuderbird from being updated, for now at least:

dnf install python3-dnf-plugin-versionlock
dnf versionlock add thunderbird-60.5.0-1.fc29

And later, when the bug is fixed, to unlock it:

dnf versionlock delete thunderbird-60.5.0-1.fc29

Builds for other architectures and versions are here: https://koji.fedoraproject.org/koji/p...

edit flag offensive delete link more

Comments

Updated with the last known good version of Thunderbird and some clarifications.

ozeszty gravatar imageozeszty ( 2019-03-07 03:55:33 -0600 )edit
0

answered 2019-03-28 13:55:17 -0600

fedy88 gravatar image

I checked the workarounds. Since 2nd March I check https://bugzilla.redhat.com/show_bug.... every day. But no workaround is working and every update of thunderbird has still the described problems - crash after start up. Are the any other workarounds? I am very unhappy that only the old downgraded version of thunderbird is working.

edit flag offensive delete link more

Comments

I tried also thunderbird-60.6.1-2.fc29.x86_64 from https://koji.fedoraproject.org/koji/p... The same thunderbird --safe-mode --ProfileManager --jsconsole --jsdebugger --devtools

(thunderbird:17965): Gtk-WARNING **: 19:58:11.137: Theme parsing error: <data>:1:34: Expected ')' in color definition

(thunderbird:17965): Gtk-WARNING **: 19:58:11.137: Theme parsing error: <data>:1:77: Expected ')' in color definition Segmentation fault

fedy88 gravatar imagefedy88 ( 2019-03-28 13:59:41 -0600 )edit

None of the workarounds from my post work, even with --safe-mode parameter?

The issue is caused by some wayland related patches added only in Fedora, that neither were fixed nor reverted. Upstream version should work: https://www.thunderbird.net/en-US/thu...

ozeszty gravatar imageozeszty ( 2019-03-28 16:31:06 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2019-03-02 01:39:11 -0600

Seen: 251 times

Last updated: Mar 28 '19