Mount NTFS partition from disk utility

asked 2019-02-28 07:32:52 -0600

Mazzofab gravatar image

updated 2019-02-28 13:14:32 -0600

I have setup a partiton that is shared with a windows dual boot on my laptop with the disk utility in Fedora 29. The issue that I am facing is that it is mounted at boot but only in read only mode. I have tried to add the rw options in the extra parameters but it does not solve the problem. Any suggestion appreciated.

FSTAB

/dev/mapper/fedora-root /
ext4 defaults 1 1 UUID=cbf04879-aa4b-4ada-b228-ef6d6afb4226 /boot ext4
defaults 1 2 UUID=6A5C-76E1
/boot/efi vfat
umask=0077,shortname=winnt 0 2 /dev/mapper/fedora-home /home
ext4 defaults 1 2 /dev/mapper/fedora-swap swap
swap defaults 0 0

UUID=7f7dd729-d3d3-4d7b-904c-deb3d860ce28

/data ext4 defaults 1 2

/dev/disk/by-uuid/7f7dd729-d3d3-4d7b-904c-deb3d860ce28

/mnt/7f7dd729-d3d3-4d7b-904c-deb3d860ce28 auto nosuid,nodev,nofail,x-gvfs-show 0 0

/dev/disk/by-uuid/4F9E5D2437B4DD30 /mnt/4F9E5D2437B4DD30 auto

nosuid,nodev,nofail,x-gvfs-show,x-gvfs-name=Shared 0 0 /dev/disk/by-uuid/72DCA4D707FE1FA3 /mnt/72DCA4D707FE1FA3 auto nosuid,nodev,nofail,x-gvfs-show,rw 0 0

MTAB

sysfs /sys sysfs rw,nosuid,nodev,noexec,relatime 0 0 proc /proc proc rw,nosuid,nodev,noexec,relatime 0 0 devtmpfs /dev devtmpfs rw,nosuid,size=16378012k,nr_inodes=4094503,mode=755 0 0 securityfs /sys/kernel/security securityfs rw,nosuid,nodev,noexec,relatime 0 0 tmpfs /dev/shm tmpfs rw,nosuid,nodev 0 0 devpts /dev/pts devpts rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000 0 0 tmpfs /run tmpfs rw,nosuid,nodev,mode=755 0 0 tmpfs /sys/fs/cgroup tmpfs ro,nosuid,nodev,noexec,mode=755 0 0 cgroup2 /sys/fs/cgroup/unified cgroup2 rw,nosuid,nodev,noexec,relatime,nsdelegate 0 0 cgroup /sys/fs/cgroup/systemd cgroup rw,nosuid,nodev,noexec,relatime,xattr,name=systemd 0 0 pstore /sys/fs/pstore pstore rw,nosuid,nodev,noexec,relatime 0 0 efivarfs /sys/firmware/efi/efivars efivarfs rw,nosuid,nodev,noexec,relatime 0 0 bpf /sys/fs/bpf bpf rw,nosuid,nodev,noexec,relatime,mode=700 0 0 cgroup /sys/fs/cgroup/devices cgroup rw,nosuid,nodev,noexec,relatime,devices 0 0 cgroup /sys/fs/cgroup/pids cgroup rw,nosuid,nodev,noexec,relatime,pids 0 0 cgroup /sys/fs/cgroup/net_cls,net_prio cgroup rw,nosuid,nodev,noexec,relatime,net_cls,net_prio 0 0 cgroup /sys/fs/cgroup/freezer cgroup rw,nosuid,nodev,noexec,relatime,freezer 0 0 cgroup /sys/fs/cgroup/perf_event cgroup rw,nosuid,nodev,noexec,relatime,perf_event 0 0 cgroup /sys/fs/cgroup/cpuset cgroup rw,nosuid,nodev,noexec,relatime,cpuset 0 0 cgroup /sys/fs/cgroup/cpu,cpuacct cgroup rw,nosuid,nodev,noexec,relatime,cpu,cpuacct 0 0 cgroup /sys/fs/cgroup/memory cgroup rw,nosuid,nodev,noexec,relatime,memory 0 0 cgroup /sys/fs/cgroup/hugetlb cgroup rw,nosuid,nodev,noexec,relatime,hugetlb 0 0 cgroup /sys/fs/cgroup/blkio cgroup rw,nosuid,nodev,noexec,relatime,blkio 0 0 configfs /sys/kernel/config configfs rw,relatime 0 0 /dev/mapper/fedora-root / ext4 rw,relatime 0 0 debugfs /sys/kernel/debug debugfs rw,relatime 0 0 mqueue /dev/mqueue mqueue rw,relatime 0 0 hugetlbfs /dev/hugepages hugetlbfs ...

(more)
edit retag flag offensive close merge delete

Comments

pls execute as root:

cat /etc/fstab
cat /etc/mtab
cat /proc/mounts
rdtcustomercare gravatar imagerdtcustomercare ( 2019-02-28 10:43:48 -0600 )edit

These lines:

/dev/disk/by-uuid/7f7dd729-d3d3-4d7b-904c-deb3d860ce28 /mnt/7f7dd729-d3d3-4d7b-904c-deb3d860ce28 auto nosuid,nodev,nofail,x-gvfs-show 0 0
/dev/disk/by-uuid/4F9E5D2437B4DD30 /mnt/4F9E5D2437B4DD30 auto nosuid,nodev,nofail,x-gvfs-show,x-gvfs-name=Shared 0 0 
/dev/disk/by-uuid/72DCA4D707FE1FA3 /mnt/72DCA4D707FE1FA3 auto nosuid,nodev,nofail,x-gvfs-show,rw 0 0

Look at the options:

nofail => only usefull for removeable media

only one is mounted RW and thats after the comment section ( all x-* options are comments )

move "rw," infront of every option line and try again.

rdtcustomercare gravatar imagerdtcustomercare ( 2019-03-01 04:20:10 -0600 )edit

AND.. they are mounted by root, means, your not the owner of that tree and therefore don't have write rights per se. Allow it via chmod 777 on your mountpoint, or mount it as user: add "uid=<uid>,gid=<gid>" as options. You can give the dir and filesmods on that mountpoint with "dir_mode=0750,file_mode=0750" or what you need, on mount.

rdtcustomercare gravatar imagerdtcustomercare ( 2019-03-01 05:28:31 -0600 )edit