Ask Your Question
0

Ethernet port not working fedora 24

asked 2019-02-26 09:45:03 -0600

rickertgeo gravatar image

updated 2019-02-28 01:20:27 -0600

Hello everyone,

I've bought a server with 3 rj45 ethernet ports on it. I've installed fedora 24 server on it and updated dnf. Now I'm trying to use the ethernet ports and one of them doesn't seem to be working.

So there is 1 PCI-e card with a single rj45 port and the motherboard has 2 rj45 ports. One of the ports on the motherboard is not working.

Supposively there is a intel i211-AT chipset and a i219-LM chipset on the motherboard. The manufacturor claims that the port thats not working for me is the intel i219-LM chipset.

I't seems to be running on e1000e drivers which I have just updated. (updated to try and get it working).

Here are some outputs:

Here are some outputs that may come in handy:

~# lspci -nn | grep -i net

00:1f.6 Ethernet controller [0200]: Intel Corporation Ethernet Connection (7) I219-LM [8086:15bb] (rev 10)
02:00.0 Ethernet controller [0200]: Intel Corporation 82574L Gigabit Network Connection [8086:10d3]
05:00.0 Ethernet controller [0200]: Intel Corporation I211 Gigabit Network Connection [8086:1539] (rev 03)

~# grep -i 8086d000015bb /lib/modules/4.11.12-100.fc24.x86_64/modules.*

/lib/modules/4.11.12-100.fc24.x86_64/modules.alias:alias pci:v00008086d000015BBsv*sd*bc*sc*i* e1000e

Is there anyone that can help me?

Edit:

    ~# ip link

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000 link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: enp2s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP mode DEFAULT group default qlen 1000 link/ether 00:1b:21:3a:23:14 brd ff:ff:ff:ff:ff:ff
3: enp5s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN mode DEFAULT group default qlen 1000 link/ether 00:01:29:93:9f:5a brd ff:ff:ff:ff:ff:ff


~#lsmod

Module                  Size  Used by
fuse                  102400  3
ip6t_rpfilter          16384  1
ip6t_REJECT            16384  2
nf_reject_ipv6         16384  1 ip6t_REJECT
xt_conntrack           16384  13
ip_set                 36864  0
nfnetlink              16384  1 ip_set
ebtable_nat            16384  1
ebtable_broute         16384  1
bridge                143360  1 ebtable_broute
stp                    16384  1 bridge
llc                    16384  2 bridge,stp
ip6table_nat           16384  1
nf_conntrack_ipv6      20480  8
nf_defrag_ipv6         36864  1 nf_conntrack_ipv6
nf_nat_ipv6            16384  1 ip6table_nat
ip6table_mangle        16384  1
ip6table_security      16384  1
ip6table_raw           16384  1
iptable_nat            16384  1
nf_conntrack_ipv4      16384  7
nf_defrag_ipv4         16384  1 nf_conntrack_ipv4
nf_nat_ipv4            16384  1 iptable_nat
nf_nat                 28672  2 nf_nat_ipv6,nf_nat_ipv4
nf_conntrack          131072  6 nf_conntrack_ipv6,nf_conntrack_ipv4,nf_nat_ipv6,xt_conntrack,nf_nat_ipv4,nf_nat
iptable_mangle         16384  1
iptable_security       16384  1
iptable_raw            16384  1
ebtable_filter         16384  1
ebtables               32768  3 ebtable_filter,ebtable_nat,ebtable_broute
ip6table_filter        16384  1
ip6_tables             28672  5 ip6table_mangle,ip6table_filter,ip6table_security,ip6table_raw,ip6table_nat
vfat                   20480  1
fat                    69632  1 vfat
i915                 1490944  0
intel_rapl             20480  0
x86_pkg_temp_thermal    16384  0
intel_powerclamp       16384  0
coretemp               16384  0
drm_kms_helper        151552  1 i915
kvm_intel             200704  0
drm                   348160  2 i915,drm_kms_helper
kvm                   598016  1 kvm_intel
snd_hda_intel          40960  0
snd_hda_codec         126976  1 snd_hda_intel
snd_hda_core           81920  2 snd_hda_intel,snd_hda_codec ...
(more)
edit retag flag offensive close merge delete

Comments

2

is there any reason why you installed an outdated os ?

rdtcustomercare gravatar imagerdtcustomercare ( 2019-02-27 06:05:14 -0600 )edit

please add the output of :

ip link
lsmod
dmesg
lshw

lshw will give a lot of output, but we need this part:

*-network
                description: Ethernet interface
                product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
                physical id: 0
                bus info: pci@0000:02:00.0
                logical name: enp2s0
               ...

configuration: autonegotiation=on broadcast=yes driver=r8169 duplex=full firmware=rtl8168f-1_0.0.5 06/18/12 ip=192.168.0.34 latency=0 link=yes multicast=yes port=MII speed=1Gb

rdtcustomercare gravatar imagerdtcustomercare ( 2019-02-27 06:09:11 -0600 )edit

Thank you for your response. The reason I am using an outdated version of Fedora is because our software was tested- and has always been running on fedora 24. We want to hold on to this version as long as possible. I have editted my orignal post with your suggested output ( I have trimmed some of them down a bit). Please have a look.

rickertgeo gravatar imagerickertgeo ( 2019-02-28 01:24:23 -0600 )edit

I presume that you installed Fedora from a LiveUSB or LiveDVD. Try booting from that, and see if the port responds. If not, you may have a bad port.

sideburns gravatar imagesideburns ( 2019-02-28 02:59:32 -0600 )edit

@rickertgeo: that "as long as possible" point was 2 years ago. You have several security problems on your fedora installation assuming you had a full installation and not just a downsized minimal installation, and even that can have sec problems now. The kernel alone has severals seriose bugs. ssh alone has a 36 year old bug, found this year.

do yourself a favour: UPGRADE to a maintained version => F28 has still 5 months to go.

rdtcustomercare gravatar imagerdtcustomercare ( 2019-02-28 11:09:42 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2019-02-28 05:06:33 -0600

rickertgeo gravatar image

The problems i was having were caused by a bad flag in newer kernels. I had to delete the e1000e module and compile new drivers followed by an kernel image update.

edit flag offensive delete link more

Comments

Now, go ahead and update your server to some supported release: https://apps.fedoraproject.org/packag... Anything you don't find here, is not supported and vulnerable to threads. Here is another way to check out supported releases.

florian gravatar imageflorian ( 2019-02-28 15:24:58 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2019-02-26 09:40:06 -0600

Seen: 196 times

Last updated: Feb 28 '19