Ask Your Question
0

after upgrade Fedora 29 can't boot any version

asked 2019-02-25 19:37:48 -0600

TheoTrav gravatar image

updated 2019-02-26 11:01:28 -0600

I have a Dell tower that was running Fedora 28 workstation for a long time (I have 3 version of the version 28 kernel as well as a rescue image). I upgraded to Fedora 29 and now my machine won't boot from ANY of my kernels. When I try to use the Fedora 29 kernel, processing stops right after the Gnome Display Manager starts. When I got to Fedora 26 rescue image, I hang with "start job waiting for Hold". When I turn off quiet mode, it appears that I'm bringing up version 29 no matter what image I select. I can't get to a terminal window to try and get logs and have tried nomodeset and various other paramters from the boot command line to no avail.

edit retag flag offensive close merge delete

Comments

IF gdm starts, usually you can use ALT+CTRL+F3 to get to a text console.

sounds more like something went wrong with the update itself.

if any other method fails:

boot to level 3
become root
dnf reinstall *

It should fix half done upgrade steps , but will take a while.

rdtcustomercare gravatar imagerdtcustomercare ( 2019-02-26 16:57:46 -0600 )edit

It didn't appear that there was a problem with gdm and when I tried to switch screens, all of them were non-functioning. I'll give your suggestion a try and let you know how it worked.

TheoTrav gravatar imageTheoTrav ( 2019-02-27 07:40:50 -0600 )edit

When I try to run the dnf reinstall, it says no packages marked...

TheoTrav gravatar imageTheoTrav ( 2019-02-27 07:43:25 -0600 )edit
1

You will need to quote the "*",. If you don't, the shell will replace it by the file names of the current directory. Thus

dnf reinstall '*'
villykruse gravatar imagevillykruse ( 2019-02-27 09:26:43 -0600 )edit

I see that you've got nouveau blacklisted, did you have nvidia proprietary driver previously installed? Maybe fixing it will suffice, how to do it depends on your GPU and previously used driver.

ozeszty gravatar imageozeszty ( 2019-02-27 11:23:12 -0600 )edit

5 Answers

Sort by » oldest newest most voted
0

answered 2019-03-01 08:48:07 -0600

TheoTrav gravatar image

I've tried all of the suggestions to no avail. The only thing I haven't done is to get rid of all NVIDIA drivers and change the boot line to unblock nouveau. In the meantime, starting up in multiuser and doing a startx is working for me.

edit flag offensive delete link more

Comments

that can't be the solution. Can you please try to downgrade plymouth and check it something is changing?

rdtcustomercare gravatar imagerdtcustomercare ( 2019-03-03 17:03:34 -0600 )edit

I would but I'm not sure of the process to downgrade plymouth. Right now, all of my images work when I use multiuser and do a "startx" - I'm happy with this solution, as kludgy as it is.

TheoTrav gravatar imageTheoTrav ( 2019-03-06 15:19:03 -0600 )edit
0

answered 2019-02-28 17:29:47 -0600

ozeszty gravatar image

Hi, since you're using GeForce 6800, try running it on nouveau. RPMFusion EOLed 304 branch of Nvidia drivers with Fedora 27, it's possible that drivers you were using with F28 are no longer updated for F29, recent kernels and XOrg, so that might be the source of your troubles.

Firstly, try removing proprietary Nvidia driver - how to do that depends on how the drivers were installed. Then unblock nouveau - this should also be a part of blob's uninstallation guide.

Feature support for NV40 cards is quite good: https://nouveau.freedesktop.org/wiki/... You can expect some issues, but at least your PC should work again, and now you can also give Wayland a try.

edit flag offensive delete link more
0

answered 2019-02-27 10:47:04 -0600

OmniASK gravatar image

I had the same problem, and the culprit was dbus-broker. So if you have dbus-broker enabled as well, you can try to change it to dbus-daemon.

Firstly, edit grub entry (press e when you are in a grub menu).
At the end of the line linux16 ( or similar) add single or systemd.unit=rescue.target similarly to this:
linux16 /vmlinuz-4.20.10-200.fc29.x86_64 root=/dev/mapper/fedora-root ro single
linux16 /vmlinuz-4.20.10-200.fc29.x86_64 root=/dev/mapper/fedora-root ro systemd.unit=rescue.target
And press Ctrl+X to boot into emergency mode.
You will be prompted, for root password.

When you are in the root shell, do the following:

Sometimes you need to remount your / filesystem in rw mode, so if you are in read-only mode:
# mount -o remount,rw /

  1. systemctl status dbus (if you see dbus-broker anywhere instead of dbus-daemon) then:
  2. systemctl disable dbus
  3. systemctl enable dbus-daemon
  4. Reboot and see the changes.
edit flag offensive delete link more

Comments

Did the systemctl enable dbus and it is active(running)/

TheoTrav gravatar imageTheoTrav ( 2019-02-28 07:32:24 -0600 )edit
0

answered 2019-02-26 11:31:29 -0600

TheoTrav gravatar image

updated 2019-02-27 07:36:56 -0600

After reading some other posts, I edited the Grub statement on my rescue image and added the number one (1) to the end of the linux16 statement, like this: linux16 /vmlinuz-4.20.10-200.fc29.x86_64 root=/dev/mapper/fedora-root ro rd.lvm.lv=fedora/root rd.lvm.lv=fedora/swap rhgb nouveau.noaccell=1 quiet LANG=en_US.UTF-8 /dev/sdb1 rd.driver.blacklist-nourveau 1

This got me to emergency mode where I can now access the OS through a command line!! I will edit this answer as I move forward. I immediately notices that "1" did not provide me with network access (ifconfig command only showed local address of 127.0.0.0). Rebooted with a "3" at the end of the command above and got network access. Logged in and performed a dnf upgrade (sudo dnf upgrade --refresh) which downloaded upgrade info for Fedora 29. Thought that this would have helped but I still stop right after the desktop manager attempts to start. I got around the issue by booting to level 3 without the "rhgb" parm on the boot line. This took me to the command line where I logged in and then did a "startx" . This worked! Going to leave well enough alone.

edit flag offensive delete link more

Comments

stupid question:

inux16 /vmlinuz-4.20.10-200.fc29.x86_64 root=/dev/mapper/fedora-root ro rd.lvm.lv=fedora/root rd.lvm.lv=fedora/swap rhgb nouveau.noaccell=1 quiet LANG=en_US.UTF-8 /dev/sdb1 rd.driver.blacklist-=##nourveau## 1

thats misspelled and maybe the cause of your problems. It does not blacklist it and if you have nvidia drivers installed, they will collide with the fanciests of problems.

The correct way to blacklist it is :

rd.driver.blacklist=nouveau nouveau.modeset=0 modprobe.blacklist=nouveau

and that your desktop is slow, isn't a wonder with disabled hardware acclerati

rdtcustomercare gravatar imagerdtcustomercare ( 2019-02-27 16:03:28 -0600 )edit

The spelling error resulted when I transcribed the line to this case - it's ok on my machine.

TheoTrav gravatar imageTheoTrav ( 2019-02-28 07:29:18 -0600 )edit

and the rest of the line ?

rdtcustomercare gravatar imagerdtcustomercare ( 2019-02-28 09:43:37 -0600 )edit
0

answered 2019-02-26 16:11:40 -0600

TheoTrav gravatar image

After I couldn't find anything in dmesg or the journal, I added the following to the boot line system.debug-shell. I was then able to go to tty 9 and run "top" - I found that the Plymouthd was hanging and I killed it (sudo kill -9 PID of Plymouth). I was then able to start the gnome desktop on TTY 2. It's slow but at least it's working. Now I can find out what the other problems are and fix them (hopefully)...

edit flag offensive delete link more

Question Tools

Stats

Asked: 2019-02-25 19:04:05 -0600

Seen: 316 times

Last updated: Feb 28 '19