Ask Your Question
0

Optimal performance on Fedora 29 with i5 6300hq skylake + gtx 960m [closed]

asked 2019-02-25 05:58:40 -0600

J-David gravatar image

updated 2019-02-25 16:12:05 -0600

Hello mates, i'm completely new to fedora universe, installed it yesterday and i'm enjoying it :) but as you can see i have a troublesome setup on my laptop for linux, a i5 6300hq skylake and a gtx 960m (hybrid, alongside a intel graphics 530). So, instalation happened without any issues, but on the very first boot after instalation i had to add "nouveau.modeset=0" as kernel parameter to make it boot, otherwise it hangs on "starting gdm".

Anyway, my question is, which steps/tweaks should i do to get a optimal performance from my skylake processor? Sometimes i feel microstutterings doing simple tasks. Another thing, whats the best approach to make my gpu to work? I have a hybrid graphics card (gtx 960m), but according to link: (https://docs.fedoraproject.org/en-US/...) i might don't have a optimus notebook since i didnt found "/sys/kernel/debug/vgaswitcheroo/switch" file and my card isn't new at the point nouveau can't use it (i guess).

Resuming:

  1. Steps/Tweaks for skylake optimal performance (i5 6300hq);
  2. Best approach to install my gtx 960m considering what i described before (bumblebee, proprietary drivers, nvidia xrun not sure if its available on fedora, nouveau, etc..)

Sorry for my bad english, i'm still learning, hope you guys can understand.

Thanks a lot and have a good day!!

Edit 1: Solved issue by adding acpi_osi=! acpi_osi='Windows 2009' to kernel parameters since i have a American Megatrends Bios, then installed bumblebee + nvidia proprietary drivers following steps on fedora docs i mentioned before.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by J-David
close date 2019-02-25 16:13:11.608169

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-02-25 09:12:56 -0600

You will need "bumblebee" ( google it ) . It's the linux approach to a dual gpu laptop.

Your 980m will be found by lspci as 3d-accellerator, right ? In this case install bumblebee and make a short setup. It's not that complicated any more.

check: lspci | grep -i 3d

After the installation of bumblebee, you will get a new cmd : optirun .

any app, that needs the 980m 3d acceleration has to be started with optirun :

optirun supertuxkart.../start_me.sh

if you wanne experiment with it :

optirun /bin/bash

any cmd you will run in that bash will use the nvidia gpu, instead of the intel soc one.

Cinnamon once had options build in, where you could choose the gpu to use before the app got started, no idea why they removed it. If you want some system apps to be executed on nvidia, you can:

cp /usr/share/applications/appname.desktop /home/username/Desktop/appname.desktop

and edit the exec line in the copied field. Add optirun infront of it, to have your tool executed via the nvidia gpu.

Hope this helps.

edit flag offensive delete link more

Comments

Thanks a lot for your quick resposnse :). Yes, its listed as 3d-accelerator since it shows up when i run "lspci | grep -i 3d". So, basically should i ignore the fact i dont have the "/sys/kernel/debug/vgaswitcheroo/switch" file and consider my laptop as optimus? My only concern with bumblebee is that some distros flagged it as abbandoned and suggests nvidia-xrun (at least arch linux, where i came from). Then it should be safe to follow the steps on Link: (https://docs.fedoraproject.org/en-US/...) right? Thanks again!

J-David gravatar imageJ-David ( 2019-02-25 09:54:59 -0600 )edit

i'm running it on an i5 with fedora 28 and it s working. there is a how to on the fedoraproject pages you can try.

rdtcustomercare gravatar imagerdtcustomercare ( 2019-02-25 13:46:04 -0600 )edit

Well, i installed bumblebee and nvidia proprietary drivers as described on fedora docs for optimus, and now my fedora hangs on splash screen unresponsive...

Edit 1: had to perform a level 2 boot to uninstall bumblebee and nvidia proprietary drivers to boot on system again.

Edit 2: managed to solve it by adding acpi_osi=! acpi_osi='Windows 2009' on kernel parameters as described on troubleshooting session of fedora docs for optimus instalation and reinstalled bumblebee + nvidia drivers following steps on same doc. Marking thread as solved.

J-David gravatar imageJ-David ( 2019-02-25 14:45:53 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2019-02-25 05:58:40 -0600

Seen: 95 times

Last updated: Feb 25 '19