xrandr error after connecting different monitor

asked 2019-02-25 05:38:45 -0500

updated 2019-02-25 08:49:38 -0500

I carry my laptop from meeting to meeting, and I regularly get an error when I try to activate a new monitor using xrandr after connecting it. Then, once the error is thrown, the laptop will refuse to connect with _any_ external monitors, even ones that it was previously connected to. The only way to solve the problem (that I have found) is to reboot the laptop.

Below is a dump of the information that I've gathered so far. This has been driving me up the wall for months now, so if anyone has any idea how I might fix it I'd be a very happy little camper indeed!

System information:

  • Fedora version: 29.
  • I use i3 as a window manager, version 4.16-1.fc29.

Debugging info:

  • xrandr --output DP-1-2 --auto response
    • xrandr: Configure crtc 1 failed
  • dmesg output
    • [14992.073171] [drm:intel_mst_pre_enable_dp [i915]] *ERROR* failed to allocate vcpi
  • /var/log/Xorg.1.log
    • [ 14913.524] (II) modeset(0): Modeline "3840x2160"x0.0 533.25 3840 3888 3920 4000 2160 2163 2168 2222 -hsync -vsync (133.3 kHz eP)
    • [ 14989.363] (II) modeset(0): Allocate new frame buffer 1920x2280 stride
    • [ 14989.447] (EE) modeset(0): failed to set mode: Invalid argument

I can provide a longer stacktrace on request, though these seem to be the relevant sections.

edit retag flag offensive close merge delete

Comments

can you mark the stacktrace as code ( 101010 button in the editor )m it will make it better readable

did it happen on a previous release too? does it happen on a different windowmanager?

I don't think it's a common problem, as my laptop i.e. does connect to dozens of different displays and has no problem with it.

rdtcustomercare gravatar imagerdtcustomercare ( 2019-02-25 08:58:16 -0500 )edit

looks like you already found the important message: "modeset(0): failed to set mode: Invalid argument"

unfortunately i can't help you here :(

rdtcustomercare gravatar imagerdtcustomercare ( 2019-02-25 09:16:53 -0500 )edit