Ask Your Question
0

NVIDIA primusrun works but optirun wont

asked 2019-02-23 15:56:28 -0600

revolucion09 gravatar image

Hi,

Installed bumblebee and primus following the fedora documentation here: https://docs.fedoraproject.org/en-US/...

My intention is to run Steam games using discrete Graphics.

Testing optirun on glxspheres64, I have way better performance than using primusrun. However, Steam won't launch any games using optirun.

I think this is because I dont have installed optirun for 32bit. Documentation doesn't say how to do it. Also copr package repository only has x86_64. Any ideas?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2019-02-23 17:08:16 -0600

revolucion09 gravatar image

updated 2019-02-26 13:39:23 -0600

Fixed. Added the repository mentioned here (manually) https://github.com/chenxiaolong/fedor...

add 32-bit repo: sudo dnf config-manager --add-repo https://copr-be.cloud.fedoraproject.o...

32-bit primus libs sudo dnf install primus-libs.i686

In any case, using primusrun for games is better (steam overlay works better, etc) and more stable

On steam game launcher properties do: primusrun %command%

edit flag offensive delete link more

Comments

Hi there! Can you please describe what you did to solve the issue? I'm facing the same issue, for steam to work properly, i need to install 32bit stuff. Thanks!!

J-David gravatar imageJ-David ( 2019-02-25 20:34:49 -0600 )edit

Updated the entry

revolucion09 gravatar imagerevolucion09 ( 2019-02-26 13:38:57 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2019-02-23 15:56:28 -0600

Seen: 142 times

Last updated: Feb 26 '19