Ask Your Question
1

Nvidia g-sync/freesync

asked 2019-02-23 07:35:03 -0600

johanh gravatar image

updated 2019-03-06 01:29:35 -0600

Has anyone got g-sync working in a game with the latest Nvidia 418.43 driver with a freesync monitor?

I have a freesync monitor (Samsung CF791) that reportedly works with Nvidia driver now when checked "Allow G-SYNC on monitor not validated as G-SYNC Compatible". At least on Windows.

Monitor has freesync on. This is picked up by the driver, so the options are then available in nvidia-settings. I also turned the Visual Indicator on in settings.

But I cannot get the indicator to show in any game. Supposedly it should show Normal or G-SYNC, but it shows nothing.

Could this be a gnome problem?

edit retag flag offensive close merge delete

Comments

Phoronix got it working. But I don't know which distro (though they use Fedora a lot). https://www.phoronix.com/scan.php?pag...

johanh gravatar imagejohanh ( 2019-02-24 03:52:45 -0600 )edit

I'm beginning to suspect this is a gnome/mutter problem, not allowing flipping, instead fallback to blitting.

https://devtalk.nvidia.com/default/to...

In Arch linux it is supposedly solved with patches (gnome-shell-performance and mutter-781835-workaround in AUR).

johanh gravatar imagejohanh ( 2019-02-25 11:05:45 -0600 )edit

Looks like the patched packages in AUR are based on some Canonical work. Hopefully this will be upstreamed in next major gnome release.

https://aur.archlinux.org/packages/gn...https://aur.archlinux.org/packages/mu...

I was able to rebuild gnome-shell with the patch, but it doesn't work without the mutter patch (only got a black screen). Need to try to build mutter, too.

johanh gravatar imagejohanh ( 2019-02-25 11:57:25 -0600 )edit

I rebuilt mutter too with the patches from AUR, but I couldn't get gnome-shell to work at all. I only got a black screen after reboot.

johanh gravatar imagejohanh ( 2019-02-25 12:41:42 -0600 )edit

Works fine on LXDE instead of gnome. Nvidia vsync indicator says FLIP (instead of BLIT) and GSYNC indicator shows. This means it is probably fullscreen window unredirecting that is broken in gnome.

johanh gravatar imagejohanh ( 2019-02-26 10:32:58 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2019-03-03 08:43:18 -0600

johanh gravatar image

updated 2019-03-06 01:29:57 -0600

This was a bug in gnome-shell https://gitlab.gnome.org/GNOME/gnome-...

Downgrading gnome-shell and mutter to 3.30.1 makes it work.

Edit. It will also be fixed in upcoming Gnome 3.32 release (Fedora 30).

edit flag offensive delete link more

Comments

But there is a another bug now. Sometimes starting a game with Gsync on causes a black screen. Or the screen is first visible, but as soon as touching keyboard or mouse, the actual graphics output (Displayport output) turns off and on and screen goes black (as long as game is full screen and in focus). When Alt-tab-ing out of the game display turns back on. And when turning Gsync off it works again.

Edit. This problem was fixed by unplugging display power supply and plugging again (power off/on on the display wasn't enough).

johanh gravatar imagejohanh ( 2019-03-03 14:44:09 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2019-02-23 07:35:03 -0600

Seen: 401 times

Last updated: Mar 06 '19