Ask Your Question
1

Fedora 29 - Copy Paste not Working Anymore

asked 2019-02-21 06:13:36 -0600

giuseppe gravatar image

Updgraded to Fedora 29.

Using Gnome.

Installed zsh.

Copy Paste by using keyboard does not work anymore! Same with Mouse selection + middle button/right button clik .

EDIT

I discovered that the same problem regarding Wayland is still present in F29

edit retag flag offensive close merge delete

Comments

1

Indeed, the bug report has been reopened: https://bugzilla.redhat.com/show_bug....

vmercuri gravatar imagevmercuri ( 2019-02-21 11:39:28 -0600 )edit

3 Answers

Sort by ยป oldest newest most voted
1

answered 2019-02-21 06:59:02 -0600

giuseppe gravatar image

If I disable clipit

dnf remove clipit

and reboot copy/paste is back again!

edit flag offensive delete link more

Comments

That's the culprit then. I wonder if this is installed by default on Fedora Workstation, I do have the same system but I don't have clipit installed. Running on XOrg though.

vmercuri gravatar imagevmercuri ( 2019-02-21 12:34:34 -0600 )edit
0

answered 2019-03-28 03:40:24 -0600

Glenn gravatar image

updated 2019-03-30 03:05:47 -0600

I typically use LXDE and have had similar issues with copy/paste. Check the clip board settings. For me, clip board history was set to 1 or 0. I don't know what it should be set to but 50 seems to have at least solved the issue for me.

Correction: It was the setting "Purge history after timeout" that was set to 1 second. I believe this was the issue. I unchecked the box and clipboard works fine.

edit flag offensive delete link more
0

answered 2019-03-26 23:53:32 -0600

nmgiffin gravatar image

I've had similar problems with copy/paste causing failures in some application software and the fix was also removing clipit I have CopyQ installed for cut and paste features.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2019-02-21 05:20:42 -0600

Seen: 298 times

Last updated: Mar 30 '19