Ask Your Question
2

Force Parallel Downloads in DNF

asked 2019-02-20 02:08:34 -0600

indolering gravatar image

DNF appears to be downloading metadata and packages serially, which is excruciatingly slow. Passing in max_parallel_downloads=10 to DNF does not help.

How can I force parallel downloads in DNF?

edit retag flag offensive close merge delete

Comments

Do you have excess network bandwidth? Otherwise it might be counter-productive.

villykruse gravatar imagevillykruse ( 2019-02-21 03:29:34 -0600 )edit

That parameter defaults to 3, so downloads aren't performed serially by default. You may want to add fastestmirror=1 to your /etc/dnf/dnf.conf, you are probably only having troubles with "slow" mirrors.

vmercuri gravatar imagevmercuri ( 2019-02-21 11:56:17 -0600 )edit

Same here - "dnf --refresh update" does downloads in sequence not in parallel.

Previously I had no max_parallel_downloads in dnf.conf, tried setting it to 10, nothing changed, still serial.

As for bandwidth - yes I do have ~60-80 Mbit actual usable connection speed.

Kostya Vasilyev gravatar imageKostya Vasilyev ( 2019-02-22 12:41:25 -0600 )edit

In my experience it takes a lot longer to digest the metadata than to actually download it.

villykruse gravatar imagevillykruse ( 2019-02-22 14:15:55 -0600 )edit

@vmercuri I know this, I passed in max_parallel_downloads=10 just to make sure it wouldn't change anything.

indolering gravatar imageindolering ( 2019-02-24 04:38:41 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-03-10 00:12:52 -0600

indolering gravatar image

Turns out I was just confused by the UI: I assumed that it would show a line for each parallel download, but it rotates between them on a single line. Adding fastestmirror=1 significantly increased speed.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2019-02-20 02:08:34 -0600

Seen: 606 times

Last updated: Mar 10 '19