Ask Your Question
0

Grub 2 display issue

asked 2019-02-15 09:13:21 -0600

c2yCharlie gravatar image

Hello friends,

I have recently installed Fedora 29 workstation. I am running a dual boot system (Windows 10 and Fedora). After my installation, I installed the Nvidia proprietary drivers using this link. However, after I completed the install and rebooted, I noticed that my splash screen had reverted to the text theme. I tried to fix it but nothing worked. It was then that I ran the command videoinfo during boot in the grub command terminal. To my surprise the grub responded by saying "Can't find command videoinfo". I tried to run vbeinfo but it also had the same output.

It isn't the first time that I have worked on a linux. Some time back I used to use Ubuntu and everything was fine with the grub. I don't know what is the issue exactly. I have tried everything but neither does the grub resolution change nor does the splash recover. Below is my grub config file contents -

GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
GRUB_DEFAULT=saved
GRUB_DISABLE_SUBMENU=true
#GRUB_TERMINAL_OUTPUT="console"
GRUB_CMDLINE_LINUX="rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1 resume=/dev/mapper/fedora-swap rd.lvm.lv=fedora/root rd.lvm.lv=fedora/swap rhgb quiet"
GRUB_DISABLE_RECOVERY="true"

GRUB_GFXPAYLOAD_LINUX="keep"
GRUB_VIDEO_BACKEND="efi_gop"
GRUB_TERMINAL_OUTPUT=gfxterm
#GRUB_FONT_PATH="/boot/efi/EFI/fedora/fonts/unicode.pf2"
GRUB_GFXMODE="1920x1080"

Can someone please tell me that why am I unable to change my grub resolution so that I am able to fix my splash screen? Also, what is more concerning to me is why does the grub not understand the commands videoinfo and vbeinfo? Could anyone please help me to resolve this issue for me.

Note: Secure boot is disabled and my OS is running on efi system

Thanking you all in anticipation.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2019-02-15 12:03:35 -0600

c2yCharlie gravatar image

Didn't work my friend. Is there any other way? On another forum, one user posted this answer:

Because you're still at the boot loader (text mode); installation hasn't progressed far enough where any of those commands are loaded/available.

What should I do to correct this?

edit flag offensive delete link more

Comments

The splash screen is displayed by plymouth after the kernel has loaded. Or are you not talking about the splash screen but something else? Also, there would be another splash screen before that from the UEFI firmware.

villykruse gravatar imagevillykruse ( 2019-02-15 12:40:26 -0600 )edit

No mate, I am talking about the Splash screen. Earlier it was charge but right now it displays 3 white dots and no matter how many times I change my plymouth to charge it always displays the three dots. Any idea as to what should I do?

c2yCharlie gravatar imagec2yCharlie ( 2019-02-16 00:38:34 -0600 )edit

Yes that is the splash screen as shown by plymouth. It is a fall-back node when plymouth doesn't like the level of driver support for graphics display by the hardware and the driver. As plymouth doesn't have X-windows nor wayland available, it needs to rely on the frame buffer support by the graphics software.

Suggest google for nvidia frame bufferplymouth`. I don't have Nvidea so I can't say what works and what doesn't. To make things even more complicated, there is also frame buffer things in the UEFI firmware which plays a role.

villykruse gravatar imagevillykruse ( 2019-02-16 05:47:12 -0600 )edit
0

answered 2019-02-15 10:59:39 -0600

villykruse gravatar image

The UEFI Grub loader is linked statically so it can be signed and thereby usable by secure boot. It does not include every possible grub module, and therefore you will find that certain stuff doesn't work. For example you can't use the various grub themes.

For non-UEFI boot you will have all the modules available as they will be loaded dynamically.

For setting the resolution I usualy include a "video=1280x720" to the GRUB_CMDLINE_LINUX and will force the resolution I like both for the splash screen as well as the login screen. Then I leave grub menu itself in plain text mode GRUB_TERMINAL_OUTPUT="console".

Not all video drivers are well behaved, so plymouth needs to revert to text mode. I don't know for sure, but I would guess you would need to rebuild the initrd image after you built the nvidia driver. "dracut -f". Otherwise the video driver can't be loaded until long after plymouth has started.

edit flag offensive delete link more

Comments

Please read my above posted answer.

c2yCharlie gravatar imagec2yCharlie ( 2019-02-15 12:04:05 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2019-02-15 09:13:21 -0600

Seen: 587 times

Last updated: Feb 15 '19