Ask Your Question
0

Resolution set back after each reboot using Virtual box

asked 2019-01-26 08:46:06 -0600

MartinMacke gravatar image

Hi,

I run Fedora in a virtualbox VM with Windows 10 as host. Within Fedora I can change the screen resolution without any issue, let's say to 1920x1200. However at each reboot it is back at 800x600 again. How can I ensure that the resolution is persistent?

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
0

answered 2019-02-02 07:19:16 -0600

MartinMacke gravatar image

Finally I figures out what to do. In addition to the change in /etc/default/grub, I also had to change the following seettings in the host OS:

C:\Program Files\Oracle\VirtualBox>VBoxManage.exe setextradata Fedora CustomVideoMode1 1920x1200x32

Now it works perfectly and I get the correct screen resolution directly after signing in to Fedora.

edit flag offensive delete link more

Comments

I too am running into this same exact issue. I tried changing the /etc/default/grub file as suggested by @villykruse and making the changes in my host system as you suggested above. The Virtual Machine exists inside a Standard User Profile in Windows so just to be sure, I ran the above as an administrator and I got an error that said that the Virtual Machine could not be found. I am running Windows 10 Version 10.0.17134.648 and I am running Virtual Box Version 6.0.4 r128413 (Qt5.6.2). Anyone have any other suggestions to fix this? Also, let me know if I should start a new thread for this.

nmnick89 gravatar imagenmnick89 ( 2019-03-17 15:41:11 -0600 )edit

You did replace the word Fedora by the actual name of your virtual machine in the above command line?

villykruse gravatar imagevillykruse ( 2019-03-18 01:11:32 -0600 )edit

Fedora is the actual name of my VM.

nmnick89 gravatar imagenmnick89 ( 2019-03-29 13:07:13 -0600 )edit
0

answered 2019-01-27 04:20:53 -0600

MartinMacke gravatar image

This didn't work. My grub file looks like this:

GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
GRUB_DEFAULT=saved
GRUB_DISABLE_SUBMENU=true
GRUB_TERMINAL_OUTPUT="console"
GRUB_CMDLINE_LINUX="resume=/dev/mapper/fedora-swap rd.lvm.lv=fedora/root rd.lvm.lv=fedora/swap rhgb quiet video=1920x1200"
GRUB_DISABLE_RECOVERY="true"
edit flag offensive delete link more
0

answered 2019-01-26 17:14:16 -0600

villykruse gravatar image

Try adding video=1920x1200 to the kernel command line. That is, append that to the end of the line starting with

GRUB_CMDLINE_LINUX=

just before the last " character in the file /etc/default/grub.

Then run grub2-mkconfig -o /boot/grub2/grub.cfg if booting from MBR/BIOS or grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg if booting from UEFI,

edit flag offensive delete link more

Comments

Thank you. This didn't work. My grub file looks like this:

GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
GRUB_DEFAULT=saved
GRUB_DISABLE_SUBMENU=true
GRUB_TERMINAL_OUTPUT="console"
GRUB_CMDLINE_LINUX="resume=/dev/mapper/fedora-swap rd.lvm.lv=fedora/root rd.lvm.lv=fedora/swap rhgb quiet video=1920x1200"
GRUB_DISABLE_RECOVERY="true"
MartinMacke gravatar imageMartinMacke ( 2019-01-27 04:24:25 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2019-01-26 08:46:06 -0600

Seen: 323 times

Last updated: Jan 26 '19