Ask Your Question
2

GRUB No longer shows up

asked 2019-01-01 10:18:22 -0500

Hawkx10 gravatar image

updated 2019-04-18 15:42:15 -0500

I installed Fedora 29 on a 50 GB partition of my Hard Drive and everything was fine. I used the Fedora for my internship and Windows for home use. Then one day when I tried to log into my most recent fedora it went into command line mode so I logged in using the farthest backup I had and used dnf update (or upgrade I can't tell the difference) to bring in the most recent version. However ever since then I've had to hit escape to go to the BIOS menu, hit f9 to get to the bios screen that allows me to choose which partition I boot to whereas before it automatically went to the GRUB. How can I get my computer to recognize the fedora boot and have it automatically go to GRUB again?

I thought maybe I showed what happened after I hit Esc after turning my computer on it would better illustrate my problem Startup Menu once I reach this page after hitting Esc I then hit F9. Boot Option Menu this is the page that I reach as you can see I can either boot from a file or pick Windows Boot or Fedora naturally for the purposes of this situation I choose Fedora. That takes me to this screen GRUB screen and it proceeds as normal as I am now on the Fedora partition. My question has been is there a way I can eliminate Steps 1 and 2 and just get to the GRUB screen every time I boot up as not doing anything automatically takes me to the Windows partition.

edit retag flag offensive close merge delete

Comments

Check the settings for booting from the BIOS. If you are bootable, the problem with BIOS modification can be solved easily by turning the BIOS back to its original state.Can you tell me if you can boot now?

simmon gravatar imagesimmon ( 2019-01-01 12:30:04 -0500 )edit

If I do nothing i boot to Windows if hit escape i go to vthe BIOS selection screen where I pick which to boot to, If I pick Fedora it goes to a GRUB Screen it used to go to a GRUB screen by default now it seems like /I have to force it to go to the GRUB screen (not sure if it would boot to Windows if I chose that option)

Hawkx10 gravatar imageHawkx10 ( 2019-01-01 18:21:43 -0500 )edit

Hawkx10, I am wondering if maybe when you say BIOS screen, might you be actually in the GRUB menu? Also, in your original question you say "command line mode", but which one?: Linux single user, Linux root, GRUB command line, Windows recovery? (Try "help" and "version" for clues whose command line it is.)

wallyk gravatar imagewallyk ( 2019-01-01 19:18:45 -0500 )edit

dnf update and dnf upgrade is exacly the same (except from the spelling).

villykruse gravatar imagevillykruse ( 2019-01-02 04:17:21 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
1

answered 2019-04-19 01:08:36 -0500

cmurf gravatar image

updated 2019-04-19 01:13:50 -0500

Sounds to me like the the boot-order in NVRAM has reverted to Windows by default. This happens sometimes on my HP laptop as well. The simplest solution is to boot Fedora and run efibootmgr which looks like this:

$ efibootmgr
BootCurrent: 0001
BootOrder: 0002,0001,2001,2002,2004
Boot0000* USB Hard Drive (UEFI) - Samsung Flash Drive
Boot0001* Fedora
Boot0002* Windows Boot Manager

You might see some extra items. On my computer, BootCurrent is 0001, which is a reference to Boot0001, which is the Fedora entry. The Boot0002 entry is for Windows. Note though that the BootOrder says Windows first, Fedora second. You probably see that too but maybe with different number assignments. To change the order, using my numbers as an example:

$ sudo efibootmgr --bootorder 1,2

And confirm it.

$ efibootmgr
BootCurrent: 0001
BootOrder: 0001,0002
Boot0000* USB Hard Drive (UEFI) - Samsung Flash Drive
Boot0001* Fedora
Boot0002* Windows Boot Manager

Now the order is 0001 (Fedora) first, and 0002 (Windows) second. Note, you can either include or exclude the prefix zeros. And you don't even have to include each boot entry.

All that normally matters is what's first in the bootorder because as long as that is a working entry, that's what boots. So what's the point of having something listed second and third? It's just a fallback. Now if in your case the BootOrder is already correct but it still boots Windows first, that means something else is wrong. The first step to figure that out is for you to post what you get for efibootmgr -v but for now I'm just going to assume BootOrder switched back to Windows being first.

edit flag offensive delete link more
0

answered 2019-01-02 01:42:02 -0500

updated 2019-01-02 04:57:11 -0500

The first time you boot up, grub2 will appear on your first hard disk, so you should check the disk for confirmation and status. If the grub values are modified and set incorrectly, serious problems may occur.

Changing from BIOS Legacy Mode to UEFI will cause boot problems, and will force booting of GRUB2 on a system running in UEFI mode.

Perhaps if you have two disks and you use a different operating system, use grub2 on Linux to update the boot state as follows:

First, grub2 will work on the first hard disk without changing the state set in the BIOS.

[Case1. 1Disk - 2 OS or 2Disk 2 OS]

 Check the disk status. [fdisk /dev/sdX] p Enter  q Enter
 # fdisk /dev/sda             [MS-Windows System]
 # fdisk /dev/sdb             [Linux- Fedora System]
or
 # fdisk /dev/sda1            [MS-Windows System]
 # fdisk /dev/sda2            [Linux- Fedora System]

[Case 2. grub2 update and re-install for MBR(Master Boot Record) System]

 # grub2-mkconfig -o /boot/grub2/grub.cfg 
 or
 # grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg

Sometimes the location of grub.cfg may be different. [/boot/efi/EFI/fedora/grub.cfg ]

 # grub2-install /dev/sda

Do NOT run grub2-install if you intend to boot in UEFI mode. [ @villykruse ]. Use disk to distinguish between mbr and gpt. If UEFI is supported, check gpt when checking the fdisk status.

if the boot settings are correct, you can get new the boot status and will be update for grub2 in boot process

After boot linux, logging in to linux, update grub2 with the command, and let me know the progress so that you can better troubleshoot the problem. Please let me know your results and i will be update further.

edit flag offensive delete link more

Comments

Do NOT run grub2-install if you intend to boot in UEFI mode.

villykruse gravatar imagevillykruse ( 2019-01-02 04:14:05 -0500 )edit
0

answered 2019-04-21 17:34:14 -0500

richard378 gravatar image

It sounds like your BIOS is set up to boot the wrong disk. Check your BIOS settings to see if you can change the boot order to be the Fedora drive first. I have had the same problem and this fixed my issue. Your Fedora grub should include an entry for the Windows install also.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2019-01-01 10:18:22 -0500

Seen: 230 times

Last updated: Apr 21 '19