Ask Your Question
0

Strange uptime behavior under qemu-kvm

asked 2018-12-11 11:31:35 -0600

shimm gravatar image

updated 2018-12-11 11:34:52 -0600

Hi all,

I've experienced some strange behavior on Fedora 28 client systems. I have some of them virtualized on a qemu-kvm hypervisor. All these systems take the hypervisor uptime as their own. This is really annoying, since I can not determine how long a host is up.

If I take a look in the boot log I can see this:

...snip...

[    0.000000] Hypervisor detected: KVM
[    0.000000] kvm-clock: Using msrs 4b564d01 and 4b564d00
[137891542.045328] kvm-clock: cpu 0, msr c6c01001, primary cpu clock
[137891542.045329] clocksource: kvm-clock: mask: 0xffffffffffffffff max_cycles: 0x1cd42e4dffb, max_idle_ns: 881590591483 ns

...snap...

Is there any possibility to turn this off, so that the VM takes its own uptime?

Really much thanks for any solution / suggestion! Sebastian

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-12-12 20:58:59 -0600

fcomida gravatar image

This reading might be of interest to you.

edit flag offensive delete link more

Comments

Hi, thank you for this input. I just took a look insinde this document and tried some things. For me the only thing fixing the problem ist to disable kvmclock and make the guest use TSC. Is this a good idea? And why ist this only happening to the fedora VM's and not to any ubuntu guests? Thanks!

shimm gravatar imageshimm ( 2018-12-18 10:53:35 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2018-12-11 11:31:35 -0600

Seen: 119 times

Last updated: Dec 12 '18