Ask Your Question

Programmer's dvorak for ibus?

asked 2018-11-28 18:19:00 -0600

incantator gravatar image

updated 2018-12-04 20:24:21 -0600

Hello, I'm currently using Fedora 29 KDE Spin and I'm using ibus for Korean input. The problem is that I cannot choose programmer's dvorak with ibus unlike in the default keyboard setting.

Here is the picture of the current settings.

I tried forcefully changing the dconf of ibus by overwriting 'dvorak' to 'dvorak-programmer', but it didn't work properly so I had to revert back.

Here is the output of my current ibus dconf:

[swy@localhost ~]$ dconf dump /desktop/ibus/
engines-order=['xkb:us:dvorak:eng', 'hangul']
preload-engines=['xkb:us:dvorak:eng', 'hangul']



Any help would be appreciated! I'm currently switching between the default keyboard app with ibus shortkey in order to use programmer's dvorak.

edit retag flag offensive close merge delete


Can nobody help me?

incantator gravatar imageincantator ( 2018-12-04 20:22:36 -0600 )edit

[root@orion ~]# dconf dump /desktop/ibus/ [general] engines-order=['xkb:us::eng', 'hangul'] preload-engines=['xkb:us::eng', 'hangul'] version='1.5.19'

한글에서 입력 상태를 확인합니다. Fedora29S KDE Hangul Input...Test for you! how to set upper side for set for hangul with in IBUS System and also you need to other package..for hangul Inupt or international language System.

im-setting and im-chooser...need to set for hangul System.can't read hangul font? install nhn-nanum* it'll be improve and make better use to hangul

help for you.. fedora or linux user for hangul system. take care!..... written simmon

simmon gravatar imagesimmon ( 2018-12-05 09:57:40 -0600 )edit

@simmon Hey thanks for the reply! I'm currently using ibus so I can write 한글 perfectly fine as you can see. It is just that there is no option for programmer's dvorak in ibus so whenever I hit win + space, it goes to ordinary dvorak, which is very annoying.

incantator gravatar imageincantator ( 2018-12-05 18:25:57 -0600 )edit

1 Answer

Sort by » oldest newest most voted

answered 2018-12-05 09:47:28 -0600

yeah..hi..i can help for you..

you want to use korean language....and need how to use hangul?

Fedora29S KDE Hangul is your ibus or language status...?

edit flag offensive delete link more


Hey, I can already use 한글, but I'm having difficulty using programmer's dvorak along with ibus. My configuration is almost the same as here. The selected languages can be seen on the images through the link I've provided (basically using 한글 and English(plain dvorak ATM). I'll provide any necessary or required configs or log files.

incantator gravatar imageincantator ( 2018-12-05 18:31:54 -0600 )edit

Question Tools

1 follower


Asked: 2018-11-28 18:19:00 -0600

Seen: 109 times

Last updated: Dec 05 '18