Ask Your Question
0

driver available for intel UHD 630 graphics on i5-9600k?

asked 2018-11-27 09:37:12 -0600

remklaver gravatar image

updated 2018-11-28 07:49:00 -0600

necessary driver from Intel seems not to be loaded during boot on a new desktop pc running Fedora 28 (4.19) I have the same issue using USB live boot:

output from "inxi -G" Graphics: Device-1: Intel driver: N/A Display: x11 server: Fedora Project X.org 1.19.6 driver: fbdev unloaded: modesetting,vesa resolution: 1024x768~76Hz OpenGL: renderer: llvmpipe (LLVM 6.0 256 bits) v: 2.1 Mesa 18.0.1

Although the following seems to relate to audio, this is the output from "dmesg | grep i915": [ 9.565745] snd_hda_intel 0000:00:1f.3: failed to add i915 component master (-19) [ 9.626220] snd_hda_codec_hdmi hdaudioC0D2: No i915 binding for Intel HDMI/DP codec [ 9.626362] snd_hda_codec_hdmi hdaudioC0D2: No i915 binding for Intel HDMI/DP codec

How can I load the correct driver for the Intel UHD 630 graphics?

edit retag flag offensive close merge delete

Comments

Hi, update BIOS/UEFI, system (e.g. by running dnf update --refresh) and post here output of cat /proc/cmdline.

ozeszty gravatar imageozeszty ( 2018-11-27 13:41:30 -0600 )edit

latest BIOS version and performed fedora update. This is the output from cat /proc/cmdline: BOOT_IMAGE=/vmlinuz-4.19.3-200.fc28.x86_64 root=/dev/mapper/fedora_localhost--live-root ro resume=/dev/mapper/fedora_localhost--live-swap rd.lvm.lv=fedora_localhost-live/root rd.lvm.lv=fedora_localhost-live/swap rhgb quiet LANG=en_US.UTF-8

remklaver gravatar imageremklaver ( 2018-11-27 15:11:39 -0600 )edit

The problem appears to be due to missing Intel GPU pci-id's. https://bugs.launchpad.net/ubuntu/+so...

remklaver gravatar imageremklaver ( 2018-11-28 13:30:30 -0600 )edit

mesa-18.0.5-4.fc28 is the latest (but still old) on F28, so not everything is updated.

Follow this answer https://askubuntu.com/a/1009183 but also, just in case, check BIOS settings mentioned above on this page.

And how is live-booted F29 doing on this PC? You can use updated ISOs: https://dl.fedoraproject.org/pub/alt/...

ozeszty gravatar imageozeszty ( 2018-11-28 13:38:23 -0600 )edit

same problem occurs on F29 install (updated yesterday) and live-booted

remklaver gravatar imageremklaver ( 2018-11-28 14:52:52 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-12-01 10:38:15 -0600

Kostya Vasilyev gravatar image

This worked for me - I installed kernel 4.20.0-0.rc4.git2.1.vanilla.knurd.1.fc29.x86_64 from here:

https://fedoraproject.org/wiki/Kernel...

And now my Fedora 29 has accelerated video again, woo-hoo!

PS - I see the OP is running Fedora 28. There are 4.20-RC kernels for 28 too.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2018-11-27 09:37:12 -0600

Seen: 1,663 times

Last updated: Dec 01 '18