Ask Your Question
2

No RTC device in F29 Server aarch64 at Rpi3b+

asked 2018-11-23 15:45:54 -0600

I have installed Fedora 29 aarch64 server in an raspberry pi 3b+.

I did it to learn more about fedora. I was testing the time with:

# timedatectl status
           Local time: Fri 2018-11-23 21:29:32 GMT
       Universal time: Fri 2018-11-23 21:29:32 UTC
             RTC time: n/a
            Time zone: Europe/London (GMT, +0000)
System clock synchronized: yes
          NTP service: active
      RTC in local TZ: yes

Warning: The system is configured to read the RTC time in the local time zone.
     This mode cannot be fully supported. It will create various problems
     with time zone changes and daylight saving time adjustments. The RTC
     time is never updated, it relies on external facilities to maintain it.
     If at all possible, use RTC in UTC by calling
     'timedatectl set-local-rtc 0'.

I tried to fix it as suggested:

# timedatectl set-local-rtc 0
Failed to set local RTC: No RTC device

But got the error above. Is that a problem? I think there should be an rtc device in /dev but there isn't. Should I just ignore this warning?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
3

answered 2018-11-25 04:25:30 -0600

muep gravatar image

As far as I know, none of the Raspberry Pi devices ship with an RTC device. When you cold-boot a Raspberry Pi, the clock will always be at a wrong time and the NTP service is needed to set it right.

edit flag offensive delete link more
0

answered 2018-11-23 21:47:50 -0600

villykruse gravatar image

You are already synchronized with a NTP time server, so you don't really need the Real Time Clock. Just ignore it.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2018-11-23 15:45:54 -0600

Seen: 176 times

Last updated: Nov 25 '18