Fedora 29 core dumps gnome-shell

asked 2018-11-10 10:29:58 -0600

David Lamkin gravatar image

I have installed Fedora 29 WS on two different machines (one Dell XPS 15 9550 and on an Asus), and I have the exact same symptom. Moreover, this happens so much, it's happened 3 times trying to write this question. As I said, these are fresh installs, but I noticed this issue after upgrading from f28. I then reformatted and installed f29 fresh.... Same issue. It does not seem to be a result of any program I'm actively using as the crash happens completely randomly.

The only data I get is this:

Reporter: systemd-coredum

Message: 
Process 16432 (gnome-shell) of user 1000 dumped core.

Stack trace of thread 16544:
#0  0x00007fb84c745e21 n/a (libmozjs-60.so.0)
#1  0x00007fb84c747f66 n/a (libmozjs-60.so.0)
#2  0x00007fb84c748ff6 n/a (libmozjs-60.so.0)
#3  0x00007fb84c74aabd n/a (libmozjs-60.so.0)
#4  0x00007fb84c74ad12 n/a (libmozjs-60.so.0)
#5  0x00007fb84c74b0ae n/a (libmozjs-60.so.0)
#6  0x00007fb84c51be18 n/a (libmozjs-60.so.0)
#7  0x00007fb84c515f7c n/a (libmozjs-60.so.0)
#8  0x00007fb84c5111a6 n/a (libmozjs-60.so.0)
#9  0x00007fb84e8b258e start_thread (libpthread.so.0)
#10 0x00007fb84e7e1593 __clone (libc.so.6)

Stack trace of thread 16432:
#0  0x00007fb84e8b867c pthread_cond_wait@@GLIBC_2.3.2 (libpthread.so.0)
#1  0x00007fb84c799493 _ZN7mozilla6detail21ConditionVariableImpl4waitERNS0_9MutexImplE (libmozjs-60.so.0)
#2  0x00007fb84c73415c n/a (libmozjs-60.so.0)
#3  0x00007fb84c75660c n/a (libmozjs-60.so.0)
#4  0x00007fb84c75739c n/a (libmozjs-60.so.0)
#5  0x00007fb84c757878 n/a (libmozjs-60.so.0)
#6  0x00007fb84c7579ff n/a (libmozjs-60.so.0)
#7  0x00007fb84eca8681 n/a (libgjs.so.0)
#8  0x00007fb84f526d31 n/a (libglib-2.0.so.0)
#9  0x00007fb84f52626d g_main_context_dispatch (libglib-2.0.so.0)
#10 0x00007fb84f526638 n/a (libglib-2.0.so.0)
#11 0x00007fb84f526962 g_main_loop_run (libglib-2.0.so.0)
#12 0x00007fb84e98e850 meta_run (libmutter-3.so.0)
#13 0x0000563a315f6b96 n/a (gnome-shell)
#14 0x00007fb84e708413 __libc_start_main (libc.so.6)
#15 0x0000563a315f6cee n/a (gnome-shell)

Stack trace of thread 16538:
#0  0x00007fb84e8b867c pthread_cond_wait@@GLIBC_2.3.2 (libpthread.so.0)
#1  0x00007fb84c799493 _ZN7mozilla6detail21ConditionVariableImpl4waitERNS0_9MutexImplE (libmozjs-60.so.0)
#2  0x00007fb84c7996a5 _ZN7mozilla6detail21ConditionVariableImpl8wait_forERNS0_9MutexImplERKNS_16BaseTimeDurationINS_27TimeDurationValueCalculatorEEE (libmozjs-60.so.0)
#3  0x00007fb84c515fe4 n/a (libmozjs-60.so.0)
#4  0x00007fb84c5111a6 n/a (libmozjs-60.so.0)
#5  0x00007fb84e8b258e start_thread (libpthread.so.0)
#6  0x00007fb84e7e1593 __clone (libc.so.6)

Stack trace of thread 16435:
#0  0x00007fb84e7d6371 __poll (libc.so.6)
#1  0x00007fb84f5265a6 n/a (libglib-2.0.so.0)
#2  0x00007fb84f526962 g_main_loop_run (libglib-2.0.so.0)
#3  0x00007fb84f71e79a n/a (libgio-2.0.so.0)
#4  0x00007fb84f54f48a n/a (libglib-2.0.so.0)
#5  0x00007fb84e8b258e start_thread (libpthread.so.0)
#6  0x00007fb84e7e1593 __clone (libc.so.6)

Stack trace of thread 16537:
#0  0x00007fb84e7d6371 __poll (libc.so.6)
#1  0x00007fb835eae675 poll_func (libpulse.so.0)
#2  0x00007fb835e9fc58 pa_mainloop_poll (libpulse.so.0)
#3  0x00007fb835ea02a2 pa_mainloop_iterate (libpulse.so.0)
#4  0x00007fb835ea0350 pa_mainloop_run (libpulse.so.0)
#5  0x00007fb835eae5bd thread (libpulse.so.0)
#6  0x00007fb835e4b06c internal_thread_func (libpulsecommon-12.2.so)
#7  0x00007fb84e8b258e start_thread (libpthread.so.0)
#8  0x00007fb84e7e1593 __clone (libc.so.6)

Stack trace of thread 16543:
#0  0x00007fb84e8b867c pthread_cond_wait@@GLIBC_2.3.2 (libpthread.so.0)
#1  0x00007fb84c799493 _ZN7mozilla6detail21ConditionVariableImpl4waitERNS0_9MutexImplE (libmozjs-60.so.0)
#2  0x00007fb84c7996a5 _ZN7mozilla6detail21ConditionVariableImpl8wait_forERNS0_9MutexImplERKNS_16BaseTimeDurationINS_27TimeDurationValueCalculatorEEE (libmozjs-60.so.0)
#3  0x00007fb84c515fe4 n/a (libmozjs-60.so.0)
#4  0x00007fb84c5111a6 n ...
(more)
edit retag flag offensive close merge delete

Comments

KDE is a great option, 0 problems here...

davidva gravatar imagedavidva ( 2018-11-10 13:38:59 -0600 )edit
1

I'm having the same issue with my XPS 9360. Issue occurs on both Wayland and Xorg.

Driveways23 gravatar imageDriveways23 ( 2018-11-14 15:29:33 -0600 )edit

Yeah it doesn't seem to be related to window server. May I ask, do you have your entire hard disk encrypted? That is the only common "out of the ordinary" thing I've done on both my laptops.

David Lamkin gravatar imageDavid Lamkin ( 2018-11-17 09:16:15 -0600 )edit