Fedora28 - Curses app across ssh not displaying spaces correctly

asked 2018-11-09 14:42:38 -0600

JimLewis gravatar image

updated 2018-11-09 15:16:47 -0600

I have a custom written (C, Curses) text editor that I have been using for over 20 years. It normally works great, however, starting with Fedora 28 it does not "look right" when running it over an ssh connection. In many places I can see that spaces are not being displayed properly. For example, this is one of the the Curses functions to display a string:

addstr("  F2 - Save              F8 - Search next      End  - Cursor to EOL   ");

This shows up correctly using SSH on every version of Linux, UNIX, or AIX I have ever used. However, on Fedora 28 it shows up like this:

 F2 - Save  F8 - Search next  End  - Cursor to EOL

Many of the spaces are missing between the e in Save and the next F.

I have checked the release notes but did not see anything about this change (I sure hope I didn't just miss it).

To be clear, my editor works fine locally on all Fedoras. The problem ONLY occurs when using SSH, and only when sshing to Fedora 28 or 29.

Any help on this at all GREATLY appreciated.

edit retag flag offensive close merge delete

Comments

Are the LANG and LC_* environment variables different when connecting over SSH?

johanh gravatar imagejohanh ( 2018-11-09 15:54:48 -0600 )edit
1

Unlikely that LANG and LC_* has anything to do with it. The TERM variable, however, is important.

villykruse gravatar imagevillykruse ( 2018-11-10 00:55:17 -0600 )edit

I've had character issues in the past when using SSH from older Debian versions to Fedora. But not exactly like this, I think it was problems with umlauts (maybe non-UTF vs UTF). SSH likes to use some of the client environment variables.

johanh gravatar imagejohanh ( 2018-11-10 12:04:33 -0600 )edit

Any and all suggestions appreciated. I just checked LANG, TERM, LC_ and some other things and they all match. I did find something else however. If I ssh from Fedora 28 to 29 or vice versa the problem is gone. They must have changed something again without properly documenting it in the release notes. Happens all the time on Fedora.

JimLewis gravatar imageJimLewis ( 2018-11-14 15:08:04 -0600 )edit

The command line top command uses ncurses. How does that look on a remote machine?

wallyk gravatar imagewallyk ( 2019-04-05 22:35:05 -0600 )edit