Ask Your Question
0

Rcently update errors displayed

asked 2018-10-12 07:53:59 -0600

ljhui gravatar image

Rcently I use dnf update as usual, errors appeared:

Problem 1: package librime-tools-1.2.9-1.gitdbedd73.fc27.x86_64 requires libyaml-cpp.so.0.5()(64bit), but none of the providers can be installed
- cannot install both yaml-cpp-0.6.1-4.fc27.x86_64 and yaml-cpp-0.5.3-9.fc27.x86_64
- cannot install both yaml-cpp-0.5.3-7.fc27.x86_64 and yaml-cpp-0.6.1-4.fc27.x86_64
- cannot install the best update candidate for package yaml-cpp-0.5.3-9.fc27.x86_64
- problem with installed package librime-tools-1.2.9-1.gitdbedd73.fc27.x86_64
Problem 2: package librime-tools-1.2.9-1.gitdbedd73.fc27.x86_64 requires libyaml-cpp.so.0.5()(64bit), but none of the providers can be installed
 - cannot install both yaml-cpp-0.6.1-4.fc27.x86_64 and yaml-cpp-0.5.3-9.fc27.x86_64
 - cannot install both yaml-cpp-0.5.3-7.fc27.x86_64 and yaml-cpp-0.6.1-4.fc27.x86_64
 - package mongodb-3.4.11-4.fc27.x86_64 requires libyaml-cpp.so.0.6()(64bit), but none of the providers can be installed
 - cannot install the best update candidate for package mongodb-3.4.11-2.fc27.x86_64
 - cannot install the best update candidate for package librime-tools-1.2.9-1.gitdbedd73.fc27.x86_64
Problem 3: package librime-1.2.9-1.gitdbedd73.fc27.x86_64 requires libyaml-cpp.so.0.5()(64bit), but none of the providers can be installed
- cannot install both yaml-cpp-0.6.1-4.fc27.x86_64 and yaml-cpp-0.5.3-9.fc27.x86_64
- cannot install both yaml-cpp-0.5.3-7.fc27.x86_64 and yaml-cpp-0.6.1-4.fc27.x86_64
- package mongodb-server-3.4.11-4.fc27.x86_64 requires libyaml-cpp.so.0.6()(64bit), but none of the providers can be installed
- cannot install the best update candidate for package mongodb-server-3.4.11-2.fc27.x86_64
- problem with installed package librime-1.2.9-1.gitdbedd73.fc27.x86_64

Skipping packages with conflicts:
 (add '--best --allowerasing' to command line to force their upgrade):
 yaml-cpp                   x86_64             0.5.3-7.fc27               fedora              170 k
 yaml-cpp                   x86_64             0.6.1-4.fc27               updates             171 k
Skipping packages with broken dependencies:
mongodb                    x86_64             3.4.11-4.fc27              updates              22 M
mongodb-server             x86_64             3.4.11-4.fc27              updates              20 M

Transaction Summary

 Skip  4 Packages

is there a way to fix it quickly ,I dont't want to wait for offical repo updates

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2018-10-12 09:36:09 -0600

villykruse gravatar image

The problem seems to be librime-tools, but in the repository of fedora the current version is version 1.2-18.fc27.1.

If you just did dnf update, then I would expect that librime-tools would have been included in the update, and in that way resolve the conflict.

The big question is: where did librime-tools-1.2.9-1.gitdbedd73.fc27.x86_64 come from?

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2018-10-12 07:53:59 -0600

Seen: 49 times

Last updated: Oct 12 '18