Ask Your Question
1

I am attempting to set keymaps so I can use altgr to set accent marks in French

asked 2018-10-02 22:29:12 -0500

jrnorth120 gravatar image

I have used localectl set-keymap us-intl. It sets the vc keymap. When I use localectl --no-convert set-x11-keymap us-intl system fails since it cannot compile the keymap.

Is there a different approach to setting the keymaps so I can get the French accent marks?

edit retag flag offensive close merge delete

Comments

What happens if you omit --no-convert?

fcomida gravatar imagefcomida ( 2018-10-03 10:24:58 -0500 )edit

Leaving --no-convert out of the command gives the same response - Failed to set keymap: Specified keymap cannot be compiled, refusing as invalid.

jrnorth120 gravatar imagejrnorth120 ( 2018-10-03 21:25:20 -0500 )edit

What does localectl reports when run with the following options?

list-locales, list-x11-keymap-models, list-x11-keymap-layouts

Maybe a missing localization package?

fcomida gravatar imagefcomida ( 2018-10-04 19:05:41 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-10-04 19:31:09 -0500

fcomida gravatar image

You must use:

localectl --no-convert set-x11-keymap us pc101 intl

You can choose a model closer to your actual keyboard instead of pc101:

localectl list-x11-keymap-models

and/or another variant for us layout:

localectl list-x11-keymap-variants us

edit flag offensive delete link more

Question Tools

Stats

Asked: 2018-10-02 22:29:12 -0500

Seen: 315 times

Last updated: Oct 04 '18