Ask Your Question
0

Fedora 28 audio crackling

asked 2018-09-25 09:54:18 -0600

fdsdb gravatar image

updated 2018-10-03 11:49:08 -0600

Hi All,

This is my first question, I apologize in advance for long question or lacking in clarity. I have done a fresh install to Fedora 28, but audio is crackling. I have googled around a lot trying different solutions and pulseaudio default.pa or daemon.pa configurations, without success, so restoring everything to its default. The problem is present with internal PCI card (MAudio 1010LT - ice1712 driver) and with motherboard card (now disabled by BIOS), but not present using an external firewire audio interface. The problem is present using for example Audacity, or Totem, or Ardour with jack server. But it is not present reading a mp4 video with Totem. In Audio settings panel the speaker test does not sound, and also system sounds are muted (but you can hear them in settings choosing different sound effects) Sometimes it is not present at the beginning of an audio file playing, but present after a while or repeating the play. Observing the MAudio card Envy24 Control software sometimes the sample rate changes during playback. It is not present using Open Music (Ircam software), that use its own audio libs. The system is updated. 4.18.9-200.fc28.x86_64 kernel, Gnome 3.28.2-2, Wayland. I have not tested X-org, because the system does not log with X-org, only Gnome or Gnome-classic (with same problem). My computer is a desktop dual-core AMD, specifically assembled for Linux. I come from Fedora 20. Thank you in advance for any help.

edit retag flag offensive close merge delete

Comments

This sounds like a hardware bug to me. It may be triggered by a Fedora 28 change to do more aggressive power saving. You may try to disable power saving on the specific card(s).

genodeftest gravatar imagegenodeftest ( 2018-09-27 06:54:16 -0600 )edit

Disable power saving:

For Intel audio, check whether less /sys/bus/pci/drivers/snd_hda_intel/module/parameters/power_save is 1. You may try to set it to 0 by running this command as root or with sudo: echo "0" > /sys/bus/pci/drivers/snd_hda_intel/module/parameters/power_save.

For other cards, the steps may differ, we would need to see the output of lsmod and lspci -k to help.

genodeftest gravatar imagegenodeftest ( 2018-09-27 06:54:34 -0600 )edit

Hi, Thank you for reply, I have tried your suggestion, but nothing change. I must specify that I am on a desktop computer, not laptop. I have disabled power save for internal audio (but already disabled by BIOS), and for MAudio Delta1010LT there is not a similar parameter. Here is the output of less /sys/bus/pci/drivers/snd_ice1712/module/parameters:

totale 0
drwxr-xr-x. 2 root root    0 28 set 19.32 ./
drwxr-xr-x. 7 root root    0 28 set 19.24 ../
-r--r--r--. 1 root root 4096 28 set 19.32 cs8427_timeout
-r--r--r--. 1 root root 4096 28 set 19.32 dxr_enable
-r--r--r--. 1 root root 4096 28 set 19.32 enable
-r--r--r--. 1 root root 4096 28 set 19.32 id
-r--r--r--. 1 root root 4096 28 set 19.32 index
-r--r--r--. 1 root root 4096 28 set 19.32 model
-r--r--r--. 1 root root 4096 28 set 19.32 ...
(more)
fdsdb gravatar imagefdsdb ( 2018-09-28 12:34:58 -0600 )edit

Ok, that was just a guess and my guess was wrong… :(

genodeftest gravatar imagegenodeftest ( 2018-09-30 11:17:04 -0600 )edit

No problems, thank you for your effort. Your hypothesis could be valid. I am going mad for trying to understand where is the problem... Best.

fdsdb gravatar imagefdsdb ( 2018-10-01 02:40:21 -0600 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2018-10-17 11:17:57 -0600

fdsdb gravatar image

RESOLVED: After a suggestion in a Facebook group I have tested KXstudio live release, and I have verified that audio was good. So I have remebered I could install the real time kernel by Planet CCRMA at home (http://ccrma.stanford.edu/planetccrma...) and everything now perfectly runs. No more audio problems. I had enabled CCRMA repository, so I simply have given the command sudo dnf install kernel-rt* for installing all necessary packages. Now the computer is more reactive, audio runs good, only there is a little more charge for CPU. A little question to Fedora programmers: why don't you implement this kernel characteristic in next releases? Thank you in advance.

edit flag offensive delete link more

Comments

Oh, this is a nice finding, thanks! It looks like your hardware is using a bad quality sound driver. This issue also happens on Windows some times.

genodeftest gravatar imagegenodeftest ( 2018-11-04 07:12:12 -0600 )edit
0

answered 2018-10-02 04:18:57 -0600

I had what seems to be the same issue after a fresh install. After installing the nvidia drivers I had a persistent clicking 2 clicks, gap, repeat. It would stop on video mode change, play on a new sound, change sound devices between onboard sound, gfx card sound etc then start again after 1-2 seconds. Muting the devices made no difference. Finally after exhausting all options I could think of I just reinstalled from scratch and the problem went away. I assume something glitched on the nvidia install. The clicks started during boot, before gdm started and persisted during shutdown after gdm closed.

edit flag offensive delete link more

Comments

Thank you for reply. I had considered to reinstall from scratch, but if possible I would like not to do that. I have reinstalled every package with sudo dnf reinstall \* instructions, but nothing changed. I have just now verified very strong interferences between mouse movements and audio during alsabat test, I don't know if this help.

fdsdb gravatar imagefdsdb ( 2018-10-03 11:54:00 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2018-09-25 09:54:18 -0600

Seen: 612 times

Last updated: Oct 03 '18