set systemd HandleLidSwitch=ignore, but can I get the screen to turn off?

asked 2018-09-20 13:58:22 -0500

wavis gravatar image

updated 2018-09-20 14:28:56 -0500

I just installed Fedora 28 on an XPS, and I like to run something and close the lid, so I edited logind.conf and set HandleLidSwitch=ignore, and ok great it stays on. But the screen stays on too. Can I get the screen to turn off when I close the lid? The other options for this config line in the man page for logind.conf don't seem to be useful.

I went to this older question first, just for reference: preventing lid close suspension

Edit: I tried commenting out all the customizations in logind.conf and instead turned off "suspend when laptop lid is closed" in gnome-tweaks. Looks like exactly the same behavior. I still need a way to have the screen turn off when I close the lid.

edit retag flag offensive close merge delete