Ask Your Question
1

How to set the default paper size to A4 for TexLive / Latex?

asked 2018-08-26 12:11:53 -0600

BrnVrn gravatar image

I searched for an answer, but:

It is OK to remove upstream programs, but it would be nice to explain how to work without them ...

edit retag flag offensive close merge delete

Comments

I tried texconfig-sys (that advise to use tlmgr) but without success, my documents still default to us letter. (I have to pass options to set them to A4 each time.)

BrnVrn gravatar imageBrnVrn ( 2018-08-26 12:22:28 -0600 )edit

paperconf gives me a4 too, and /etc/papersize contains a4 as well. (Not sure if it relates to Tex)

BrnVrn gravatar imageBrnVrn ( 2018-08-26 13:11:26 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2018-08-27 18:38:43 -0600

q2dg gravatar image

I don't understand the question: Isn't \documentclass[a4paper]{article} enough? If it wasn't, isn't "geometry" package helpful, then?

edit flag offensive delete link more
1

answered 2018-08-26 14:21:09 -0600

villykruse gravatar image

Check the command paperconf. Run man paperconf for the details.

The default can come from the locale:

LC_PAPER=en_US paperconf
letter

LC_PAPER=en_UK paperconf
a4

The default can also come from /etc/papersize and it seems to take precedence over the LC_PAPER variable

echo letter > /etc/papersize
paperconf
letter

echo a4 > /etc/papersize
paperconf
a4

echo legal > /etc/papersize
paperconf
legal

Or you can set the PAPERSIZE environment variable.

PAPERSIZE=a4 paperconf
a4

PAPERSIZE=letter paperconf
letter

Whether a program will respect these settings is up the the individual program.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2018-08-26 12:11:53 -0600

Seen: 357 times

Last updated: Aug 27 '18