Ask Your Question
-1

Trouble installing google chrome. Please help

asked 2018-08-21 04:13:46 -0600

klseetharam gravatar image

updated 2018-08-21 06:06:46 -0600

hhlp gravatar image

I am using fedora 20. Earlier I had installed google chrome(64 bit) and that was working fine. Recently I faced a problem as it said this version of chrome is old and not supported. It was not opening any https websites. So I uninstalled it. When I try to reinstall it, I get the following message. Help me installing it.

sudo yum install google-chrome-stable

Loaded plugins: fastestmirror, langpacks, refresh-packagekit
Loading mirror speeds from cached hostfile
 * fedora: pubmirror2.math.uh.edu
 * rpmfusion-free: rpmfusion-archive.ip-connect.vn.ua
 * rpmfusion-free-updates: rpmfusion-archive.ip-connect.vn.ua
 * rpmfusion-nonfree: rpmfusion-archive.ip-connect.vn.ua
 * rpmfusion-nonfree-updates: rpmfusion-archive.ip-connect.vn.ua
 * updates: pubmirror2.math.uh.edu
Resolving Dependencies
--> Running transaction check
---> Package google-chrome-stable.x86_64 0:68.0.3440.106-1 will be installed
--> Processing Dependency: libssl3.so(NSS_3.28)(64bit) for package: google-chrome-stable-68.0.3440.106-1.x86_64
--> Processing Dependency: libnss3.so(NSS_3.22)(64bit) for package: google-chrome-stable-68.0.3440.106-1.x86_64
--> Processing Dependency: libappindicator3.so.1()(64bit) for package: google-chrome-stable-68.0.3440.106-1.x86_64
--> Running transaction check
---> Package google-chrome-stable.x86_64 0:68.0.3440.106-1 will be installed
--> Processing Dependency: libssl3.so(NSS_3.28)(64bit) for package: google-chrome-stable-68.0.3440.106-1.x86_64
--> Processing Dependency: libnss3.so(NSS_3.22)(64bit) for package: google-chrome-stable-68.0.3440.106-1.x86_64
---> Package libappindicator-gtk3.x86_64 0:12.10.0-3.fc20 will be installed
--> Processing Dependency: libindicator3.so.7()(64bit) for package: libappindicator-gtk3-12.10.0-3.fc20.x86_64
--> Processing Dependency: libdbusmenu-gtk3.so.4()(64bit) for package: libappindicator-gtk3-12.10.0-3.fc20.x86_64
--> Processing Dependency: libdbusmenu-glib.so.4()(64bit) for package: libappindicator-gtk3-12.10.0-3.fc20.x86_64
--> Running transaction check
---> Package google-chrome-stable.x86_64 0:68.0.3440.106-1 will be installed
--> Processing Dependency: libssl3.so(NSS_3.28)(64bit) for package: google-chrome-stable-68.0.3440.106-1.x86_64
--> Processing Dependency: libnss3.so(NSS_3.22)(64bit) for package: google-chrome-stable-68.0.3440.106-1.x86_64
---> Package libdbusmenu.x86_64 0:12.10.2-5.fc20 will be installed
---> Package libdbusmenu-gtk3.x86_64 0:12.10.2-5.fc20 will be installed
---> Package libindicator-gtk3.x86_64 0:12.10.1-2.fc20 will be installed
--> Finished Dependency Resolution
Error: Package: google-chrome-stable-68.0.3440.106-1.x86_64 (google-chrome)
           Requires: libssl3.so(NSS_3.28)(64bit)
Error: Package: google-chrome-stable-68.0.3440.106-1.x86_64 (google-chrome)
           Requires: libnss3.so(NSS_3.22)(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2018-08-21 06:58:46 -0600

fcomida gravatar image

Even your version of Fedora is old and unsupported. Upgrade to Fedora 28 and you'll be fine.

edit flag offensive delete link more

Comments

Thanks. I was reluctant to update and was thinking to move to other distros. But now I will try to upgrade. Since 20 is way behind 28 Shall I go for a fresh install?

klseetharam gravatar imageklseetharam ( 2018-08-22 13:11:14 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2018-08-21 04:13:46 -0600

Seen: 351 times

Last updated: Aug 21 '18