Ask Your Question
2

display flicker black

asked 2018-07-20 08:26:34 -0600

Vladimir74 gravatar image

updated 2018-07-30 00:28:23 -0600

core 4.13 normal dual display core 4.13 > display flicker blink on first monitor and flicker black screen on second monitor

dmesg

video about blink screen

journalctl

#lspci

00:00.0 Host bridge: Intel Corporation Intel Kaby Lake Host Bridge (rev 05)
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 630 (rev 04)
00:14.0 USB controller: Intel Corporation Sunrise Point-H USB 3.0 xHCI Controller (rev 31)
00:16.0 Communication controller: Intel Corporation Sunrise Point-H CSME HECI #1 (rev 31)
00:17.0 SATA controller: Intel Corporation Sunrise Point-H SATA controller [AHCI mode] (rev 31)
00:1c.0 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #5 (rev f1)
00:1d.0 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #9 (rev f1)
00:1f.0 ISA bridge: Intel Corporation Sunrise Point-H LPC Controller (rev 31)
00:1f.2 Memory controller: Intel Corporation Sunrise Point-H PMC (rev 31)
00:1f.3 Audio device: Intel Corporation Sunrise Point-H HD Audio (rev 31)
00:1f.4 SMBus: Intel Corporation Sunrise Point-H SMBus (rev 31)
00:1f.6 Ethernet controller: Intel Corporation Ethernet Connection (2) I219-V (rev 31)

#inxi -SMCGxxxz
System:    Host: VLADIMIR Kernel: 4.17.6-200.fc28.x86_64 x86_64 bits: 64 
           compiler: gcc v: 8.1.1 
Desktop: Gnome 3.28.2 wm: gnome-shell dm: gdm Distro: Fedora release 28 (Twenty Eight) 
Machine:   Type: Desktop Mobo: ASUSTeK model: H110M-A/M.2 v: Rev X.0x serial: <filter> 
           UEFI [Legacy]: American Megatrends v: 2003 date: 09/19/2016 
CPU:       Topology: Quad Core model: Intel Core i5-7400 bits: 64 type: MCP 
           arch: Skylake rev: 9 L2 cache: 6144 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 24000 
           Speed: 1600 MHz min/max: 800/3500 MHz 
           Core speeds (MHz): 1: 1600 2: 1600 3: 1600 4: 1600 
Graphics:  Card-1: Intel HD Graphics 630 vendor: ASUSTeK driver: i915 
           v: kernel bus ID: 00:02.0 
           chip ID: 8086:5912 
           Display: x11 server: Fedora Project X.org 11.0 
           driver: i915 compositor: gnome-shell 
           resolution: 1920x1080~60Hz, 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 630 (Kaby Lake GT2) 
           v: 4.5 Mesa 18.0.5 compat-v: 3.0 
           direct render: Yes
edit retag flag offensive close merge delete

Comments

You should update your system (and upgrade to current version), there's been lots of fixes for Kaby Lake since kernel 4.13 times.

Which version of Fedora are you currently using? cat /etc/fedora-release will show you that.

ozeszty gravatar imageozeszty ( 2018-07-20 17:09:15 -0600 )edit

cat /etc/fedora-release

Fedora release 28 (Twenty Eight)
Vladimir74 gravatar imageVladimir74 ( 2018-07-22 22:17:18 -0600 )edit

only on 4.13 and below everything worked perfectly. The versions above lead to the periodic disconnection and activation of the second monitor.

Vladimir74 gravatar imageVladimir74 ( 2018-07-23 23:51:45 -0600 )edit
1

So it only happens in panorama mode? Do you see any errors in dmesg or journalctl when it happens? You can run dmesg -w to keep it running in real-time.

Edit your question and paste there output of inxi -SMCGxxxz

ozeszty gravatar imageozeszty ( 2018-07-24 03:27:54 -0600 )edit

Yes, it only happens in panorama mode.

Vladimir74 gravatar imageVladimir74 ( 2018-07-30 00:33:37 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-07-31 00:05:00 -0600

Vladimir74 gravatar image

updated 2018-07-31 00:07:16 -0600

There's an error in dmesg that needs to be reported and fixed ([drm:intelcpufifounderrunirq_handler [i915]] ERROR CPU pipe A FIFO underrun), but first:

    Update your BIOS: https://www.asus.com/us/Motherboards/H110M-A-M-2/HelpDesk_BIOS/
    Update your system dnf update --refresh

Thanks to everyone who participated in the update the BIOS really helped!

ozeszty the best ;)

edit flag offensive delete link more

Comments

You're welcome. You should be able to convert my last comment into an answer with a link under it, please do it if it's there.

ozeszty gravatar imageozeszty ( 2018-07-31 05:03:15 -0600 )edit

saw in another post on here, that comments can no longer be converted to answer.

SteveEbey73701 gravatar imageSteveEbey73701 ( 2018-07-31 07:03:20 -0600 )edit

Last time I heard, post owners and admins/moderators should be able to convert posts.

It sucks, especially when additional troubleshooting/information is required or you're not sure some steps will definitely fix the issue.

ozeszty gravatar imageozeszty ( 2018-07-31 08:29:07 -0600 )edit

Question Tools

Stats

Asked: 2018-07-20 08:26:34 -0600

Seen: 199 times

Last updated: Jul 31 '18