Ask Your Question

XAMPP error in Fedora 28?

asked 2018-07-15 00:58:13 -0500

Sagnik_Chaudhuri gravatar image

Previously, it used to work perfectly in Fedora 27. But after upgrading to Fedora 28, it shows me the following log output:

Starting Apache Web Server...
Exit code: 8
apache config test fails, aborting
httpd: Syntax error on line 522 of /opt/lampp/etc/httpd.conf: Syntax error on line 10 of /opt/lampp/etc/extra/httpd-xampp.conf: Cannot load modules/ into server: cannot open shared object file: No such file or directory

Running this showed me this:

/opt/lampp/bin/php -v
/opt/lampp/bin/php: error while loading shared libraries: cannot open shared object file: No such file or directory

Also, I went through this link, but couldn't understand. How to fix this issue?

edit retag flag offensive close merge delete


still same error.

Sagnik_Chaudhuri gravatar imageSagnik_Chaudhuri ( 2018-07-15 03:22:24 -0500 )edit

Why not just use Fedora's built-in package manager instead of downloading some packages from internet dnf install libnsl (or dnf install libnsl.i686 if you need 32-bit libnsl)?

ozeszty gravatar imageozeszty ( 2018-07-15 12:03:20 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2018-07-16 03:46:55 -0500

remi gravatar image

Using XAMPP on any Linux distribution doesn't make any sense.

Use all the packages provided in the official repository: httpd, nginx, php, mariadb, ...

edit flag offensive delete link more

Question Tools


Asked: 2018-07-15 00:58:13 -0500

Seen: 1,024 times

Last updated: Jul 16 '18