Ask Your Question
4

How do I get rid of this blinking line on Fedora 28?

asked 2018-06-27 23:01:10 -0600

InitializeSahib gravatar image

updated 2018-07-14 16:07:38 -0600

I have recently installed a Fedora 28 GNOME system. However, the display is acting strange. In the installer, and right after install, my display (a 1366x768 integrated monitor on my laptop) has a thin blinking line at the very top of it. I can't exactly measure how thin it is, but I'd say it's about 1 pixel tall; it might be thicker because it's easy to see on my screen. When I move a window around or change the content of the window, the line changes its colour and brightness. It seems to get more active as I use my computer. When I'm in the Activities Overview, the line disappears for some reason. After updating my system post-installation and rebooting, the line disappeared. However, I installed snapd to get Spotify, and after rebooting the line came back. I'm not sure if it was snapd's fault or the reboot; after removing snapd and Spotify the line remains. I'm using Intel HD Graphics (integrated) on an Intel Celeron N2830, with Mesa. It's not a hardware problem as there is no white line on other Linux distros (e.g. Arch, openSUSE, Ubuntu). The line isn't always 100% the length of the screen. Sometimes, some parts of it are very hard to see or are invisible. However, the effect of the line seems to be across the whole screen. Additionally, switching between Xorg and Wayland has no effect. Can you help me get rid of this line? Thanks!

Edit: I have now seen the white line on all distros except for Manjaro running on kernel 4.18. I'm suspecting a kernel bug.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2018-07-14 15:42:09 -0600

InitializeSahib gravatar image

updated 2018-07-14 15:42:40 -0600

I believe it's a kernel issue, as the white line has now appeared on Xubuntu running 4.15. However, it was not present on Manjaro running 4.18 or 4.17. This leads me to believe that the solution is to just wait for a new kernel.

edit flag offensive delete link more

Comments

Never mind. Updating to 4.17 on Xubuntu had no effect. I'll try 4.18 later.

InitializeSahib gravatar imageInitializeSahib ( 2018-07-14 16:06:48 -0600 )edit
0

answered 2018-06-28 07:12:49 -0600

SteveEbey73701 gravatar image

Try disabling vertical sync, or if already disabled, then try enabling it. sounds like a refresh issue with vertical sync.

edit flag offensive delete link more

Comments

I've tried toggling vertical sync by editing vblank_mode in ~/.drirc, ~/.xsession, and ~/.profile, but they all had no effect (glxgears was still running at a frame rate above 60). Either vertical sync isn't the issue, or I don't know how to toggle it properly.

InitializeSahib gravatar imageInitializeSahib ( 2018-06-28 20:38:04 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2018-06-27 23:00:48 -0600

Seen: 213 times

Last updated: Jul 14 '18