Ask Your Question
1

Can't browse Windows Network from Fedora

asked 2018-06-25 14:16:52 -0600

fasulia gravatar image

updated 2018-07-02 09:43:03 -0600

On Fedora MATE (28 and 27), I can't browse Windows Shares on a local network through Caja. In Network -> Browse Network, I get a dialog box with the error: "Unable to mount location. Failed to retrieve share list from server: No such file or directory"

However, I can access the shares with smbclient //[IP of a Windows computer]/[Share directory] in a terminal, or smb://[IP of a Windows computer]/[Share directory] in Caja's location bar.

Other computers with Ubuntu can browse the network and find shared printers connected to Windows machines.

How can I enable browsing the network in Fedora?


EDIT: After disabling the firewall with sudo systemctl stop firewalld.service I no longer get the error dialog when trying Browse Network, but it just shows an empty window with 0 items. This is the case even if the firewall is started again, until the system is rebooted.

Could it be a firewall configuration issue?


EDIT2: Changing firewall zone from Default to FedoraWorkstation got rid of the error dialog box, but browsing the network still doesn't work. Seems it has to do with network discovery. This bug report thread describes the situation and apparent solution for Solus: https://dev.solus-project.com/T1223 Is there a solution adapted to Fedora?

edit retag flag offensive close merge delete

Comments

There is also another unanswered question with a very similar problem: https://ask.fedoraproject.org/en/ques...

fasulia gravatar imagefasulia ( 2018-06-26 08:30:11 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2019-02-13 18:57:57 -0600

fasulia gravatar image

The issue seems to be that browsing SMB shares with applications / file managers using gvfs is not working, as described in this bug report: https://bugzilla.redhat.com/show_bug....

edit flag offensive delete link more
0

answered 2018-06-26 01:01:51 -0600

Rabin gravatar image

Do you have the package gvfs-smb installed ?

edit flag offensive delete link more

Comments

Yes, Package gvfs-smb-1.36.2-1.fc28.x86_64 is already installed, skipping.

fasulia gravatar imagefasulia ( 2018-06-26 08:17:09 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2018-06-25 14:16:52 -0600

Seen: 1,492 times

Last updated: Feb 13 '19