Ask Your Question
0

How do I get gnome->settings->sound to recognise my audio devices? Fedora28

asked 2018-06-09 08:45:56 -0600

dbsnyder40 gravatar image

updated 2018-08-15 18:20:02 -0600

How do I get gnome->settings->sound to recognise my audio devices?

I did a new fedora 28 installation recently but seem to have lost the sound. It was working with fedora26.
I've checked volume levels on the computer monitor, gnome sound configuration, and reseated the HDMI cable.

Gnome->settings->sound shows only the device Dummy Output

vlc shows only the device Dummy Output and does not produce audio (the video does display)

audacity shows two devices: hdmI and generic. The analog generic device works. I may have other problems with the hdmi device, but would at least like to use the one that works for now.

/proc/asound/cards shows the video chips HDMI and the motherboards analog card

0 [HDMI ]: HDA-Intel - HDA ATI HDMI HDA ATI HDMI at 0xfef44000 irq 34

1 [Generic ]: HDA-Intel - HD-Audio Generic HD-Audio Generic at 0xfef40000 irq 16

note: HDMI is the Radeon built into the AMD A6 CPU (ati driver) Generic is the Realtek ALC887-VD built into the MSI FM2-A55M-E33 mother board.

I hear nothing from: speaker-test -Dhdmi -c2 however speaker-test -Dfront:generic -c2 does produce sound

pacmd --list shows the two sound cards

I have tried pulseaudio --kill; pulseaudio --start

The gnome->setup->sound shows only the Dummy Output device, so I'm wondering if pulseaudio is not communicating with gnome. If sound is going to the Dummy Output device and no real devices, that would explain why I hear nothing.

alsa-info.sh output is at http://www.alsa-project.org/db/?f=731...

The Live-CD exhibits the same problem - but I can't boot in the normal mode and have to use the troubleshooting mode.

I'm wondering if gnome isn't finding the pulseaudio server, or if it is more fundamental, ... or something foolish that I am doing wrong.

Can I force gnome to find the audio devices?

edit retag flag offensive close merge delete

Comments

Install pavucontrol and/or paman and check which audio card is the default one.

fcomida gravatar imagefcomida ( 2018-06-14 10:22:06 -0600 )edit

Thanks, I have installed them since I first idtified the problem.

Devices -> Sinks are "auto_null (Dummy Output)

Devices -> Sources are auto_null.monitor

The Modules include:

module-udev-detect

module-alsa-card (diviceid="0" name="pci-0000001.1" cardname="alsacard.pci-0000001.1" nameregfail=false tsched=yes fixedlatencyrange=no ignoredB=no deferredvolume=yes useucm=yes cardproperties="module-udev-detect.discovered=1"

module-alsa-card (diviceid="0" name="pci-00000_14.1" ...

(continued)

dbsnyder40 gravatar imagedbsnyder40 ( 2018-06-19 09:40:23 -0600 )edit

(from continued)

pacmd>

list-cards 2 card(s) available. index: 0 name: <alsa_card.pci-0000_00_01.1> driver: <module-alsa-card.c> owner module: 6 properties: alsa.card = "0" alsa.cardname = "HDA ATI HDMI" alsa.longcardname = "HDA ATI HDMI at 0xfef44000 irq 34" alsa.drivername = "sndhdaintel" ...

name: <alsa_card.pci-0000_00_14.2>
driver: <module-alsa-card.c>
owner module: 7
properties:
    alsa.card = "1"
    alsa.card_name = "HD-Audio Generic"
    alsa.long_card_name = "HD-Audio Generic at 0xfef40000 irq 16"
    alsa.driver_name = "snd_hda_intel"

...

dbsnyder40 gravatar imagedbsnyder40 ( 2018-06-19 09:45:35 -0600 )edit

pacmd

list-sinks

1 sink(s) available. * index: 0 name: <auto_null> driver: <module-null-sink.c> flags: DECIBELVOLUME LATENCY DYNAMICLATENCY state: SUSPENDED

It looks like I have to figure out how to get pulseaudio to recognize the cards.

dbsnyder40 gravatar imagedbsnyder40 ( 2018-06-19 09:51:26 -0600 )edit

pavucontrol is interesting.

for output it shows no devices available.

configuration shows two 'Built-in Audio' devices, clicking on profile offers three choices for each, But each indicated 'unpluged' I know that at least the analog device is plugged in because 'audacity' works.

dbsnyder40 gravatar imagedbsnyder40 ( 2018-06-19 10:15:43 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2018-08-15 18:16:27 -0600

dbsnyder40 gravatar image

In searching for how to fix my problem with the display not giving choices in resolution, I came across the command:

[sudo] modprobe radeon modeset=1

It fixed the screen resolution issue, AND now the digital HDMI shows up in the sound setting menu!!! and so far, it appears to work!

I don't have a clue about what it does, but it works!

edit flag offensive delete link more

Question Tools

Stats

Asked: 2018-06-09 08:45:56 -0600

Seen: 955 times

Last updated: Aug 15 '18