Ask Your Question

plymouth-set-default-theme returns error regardless of which theme I select. [solved]

asked 2018-05-31 13:21:29 -0600

SteveEbey73701 gravatar image

updated 2018-07-09 20:53:09 -0600

This is what I get when I try to change to a different plymouth theme. Does not matter what theme I select, I only have the hot-dog on reboot, and running with -R on the plymouth command fails with same message.

 [steve@linuxbox-desktop ~]$ sudo plymouth-set-default-theme charge
[sudo] password for steve: 
/usr/local/lib/plymouth/ does not exist
[steve@linuxbox-desktop ~]$

Any suggestions, even bad ones, cause sometimes they turn out to be right.

edit retag flag offensive close merge delete


Your plymouth installation is broken. Try removing all files of plymouth in /usr/local/. Then run # dnf reinstall plymouth as root. After that, the command should work fine.

genodeftest gravatar imagegenodeftest ( 2018-06-02 03:47:02 -0600 )edit

I guess this comment would qualify as the "correct answer".

villykruse gravatar imagevillykruse ( 2018-06-02 07:01:05 -0600 )edit

@genodeftest, that did not work, came back with same error. Any other suggestions?

SteveEbey73701 gravatar imageSteveEbey73701 ( 2018-06-02 09:43:37 -0600 )edit

@steveebey73742, I guess you did not remove the plymouth-related files completely. There may also be incorrect config files lying around, e.g. in /etc. systemd unit files are possible candidates too.

genodeftest gravatar imagegenodeftest ( 2018-06-02 17:29:59 -0600 )edit

You may want to check rpm -Va for a list of all modified config files.

genodeftest gravatar imagegenodeftest ( 2018-06-02 17:32:56 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2018-05-31 14:41:15 -0600

villykruse gravatar image

You have to rebuild the initrd file. There is an option to make plymouth-set-default-theme doing that:

sudo plymouth-set-default-theme charge --rebuild-initrd
edit flag offensive delete link more


[steve@linuxbox-desktop ~]$ sudo plymouth-set-default-theme charge --rebuild-initrd [sudo] password for steve: /usr/local/lib/plymouth/ does not exist

as stated in my original question, this is s the result. Has anyone else seen this problem?

SteveEbey73701 gravatar imageSteveEbey73701 ( 2018-05-31 14:53:54 -0600 )edit

It should not even look for /usr/local/lib/plymouth/ The file is supposed to be in /usr/lib64/plymouth/ or /usr/lib/plymouth/ for 64bit and 32bit OS respectively.

This leads me to believe that your plymouth programs are not the proper ones.

villykruse gravatar imagevillykruse ( 2018-05-31 15:38:01 -0600 )edit

removed, reinstalled, same results, so what else should I try? what file would specify the path, to use to locate the .so files?

SteveEbey73701 gravatar imageSteveEbey73701 ( 2018-05-31 17:21:48 -0600 )edit

plymouth --get-splash-plugin-path /usr/local/lib/plymouth/

how do i change that?

SteveEbey73701 gravatar imageSteveEbey73701 ( 2018-05-31 17:46:04 -0600 )edit

copied the files from lib64 to the path shown in the error message, now the feature works.

SteveEbey73701 gravatar imageSteveEbey73701 ( 2018-05-31 20:02:40 -0600 )edit

answered 2018-06-02 17:49:01 -0600

genodeftest gravatar image

@steveebey73742: probably a config file or a broken package. What does $ rpm -q --info plymouth give you? What's the version, packager and vendor? What does $ dnf info plymouth give you? What are the package sources (repositories)? Have you tried dnf distro-sync to make sure you did not install the package from a foriegn broken repo.

edit flag offensive delete link more


Source RPM : plymouth-0.9.3-6.fc28.src.rpm Build Date : Tue 17 Apr 2018 08:24:50 AM CDT Build Host : Relocations : (not relocatable) Packager : Fedora Project Vendor : Fedora Project repository : @System

SteveEbey73701 gravatar imageSteveEbey73701 ( 2018-06-02 18:56:23 -0600 )edit

This does not sound like a viable solution.

genodeftest gravatar imagegenodeftest ( 2018-07-08 01:34:55 -0600 )edit

Question Tools

1 follower


Asked: 2018-05-31 13:21:29 -0600

Seen: 240 times

Last updated: Jul 09 '18