Ask Your Question
1

After upgrade to Fedora 28 cannot set locale

asked 2018-05-20 12:51:01 -0600

klacr gravatar image

updated 2018-05-20 12:52:33 -0600

When trying to set the locale, I get the following error messages:

[root@KlausPC opt]# LC_ALL=C
[root@KlausPC opt]# LC_ALL=CX
-bash: warning: setlocale: LC_ALL: cannot change locale (CX): No such file or directory
[root@KlausPC opt]# LC_ALL=de_DE.utf8
-bash: warning: setlocale: LC_ALL: cannot change locale (de_DE.utf8): No such file or directory
[root@KlausPC opt]# exit
logout
[testuser@KlausPC ~]$ LC_ALL=de_DE.utf8
bash: warning: setlocale: LC_ALL: cannot change locale (de_DE.utf8): No such file or directory
[testuser@KlausPC ~]$ su -
Password: 
-bash: Warnung: setlocale: LC_TIME: Kann die Standorteinstellungen nicht ��ndern (de_DE.UTF-8).
[root@KlausPC ~]# LC_ALL=de_DE.utf8
-bash: Warnung: setlocale: LC_ALL: Kann die Locale nicht ��ndern (de_DE.utf8): No such file or directory

Indeed there is no file named 'de_DE.utf8', but this locale is included in /usr/lib/locales/locale-archive.

[root@KlausPC ~]# locale -a | grep de_DE
de_DE
de_DE@euro
de_DE.iso88591
de_DE.iso885915@euro
de_DE.utf8
[root@KlausPC ~]# ll /usr/lib/locale/locale-archive
-rw-r--r--. 1 root root 109233616 Mar 14  2016 /usr/lib/locale/locale-archive
edit retag flag offensive close merge delete

Comments

Have you tried localectl

florian gravatar imageflorian ( 2018-05-21 08:10:41 -0600 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2018-05-20 16:10:42 -0600

villykruse gravatar image

The file /usr/lib/locale/locale-archive seems a bit old. It shoule have been upgraded by the glibc-all-langpacks package.

Try

sudo dnf install glibc-all-langpacks-2.27-8.fc28.x86_64.rpm

My locale-archive is

$ ls -l /usr/lib/locale/locale-archive
-rw-r--r--. 1 root root 209526528 Apr 29 16:36 /usr/lib/locale/locale-archive
edit flag offensive delete link more

Comments

sudo dnf install glibc-all-langpacks is enough (no need to set the version) or sudo dnf install glibc-langpack-fr to install only your language and save space disk

pdemanget gravatar imagepdemanget ( 2018-11-07 07:17:57 -0600 )edit
1

answered 2018-11-21 09:18:07 -0600

Adail Antonio gravatar image

There is a meta-package that will install all the language files that you need.

In your case, just execute:

#dnf install langpacks-de.noarch

And define the locales with:

#localectl set-locale LANG=de_DE.utf8

Normally you don't need to reboot your machine.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2018-05-20 12:51:01 -0600

Seen: 2,830 times

Last updated: May 20 '18