Upgrade Fedora 21 to 28 error / support

asked 2018-05-19 12:47:00 -0600

andre-1902 gravatar image

Hello,

I hope this is the right place to ask for support. Please note that I'm super inexperienced with Fedora.

I'm trying to upgrade from release 21 to 28 using this guide: https://fedoraproject.org/wiki/UpgradingFedorausingpackagemanager Last thing is was doing was the "Upgrade all packages" part where following error occured:

[Andre@noname ~]$ sudo dnf --releasever=28 --setopt=deltarpm=false distro-syncUsing metadata from Sat May 19 17:45:48 2018 (1:43:17 hours old) Error: package kactivities-nepomuk-4.13.3-6.fc21.x8664 requires kactivities-libs(x86-64) = 4.13.3-6.fc21, but none of the providers can be installed. package kde-plasma-folderview-6:15.04.3-1.fc21.1.x8664 requires kde-baseapps-common = 15.04.3-1.fc21.1, but none of the providers can be installed. package kde-runtime-drkonqi-15.08.1-1.fc21.x8664 requires kde-runtime = 15.08.1-1.fc21, but none of the providers can be installed. package libkgeomap-4.13.0-1.fc21.x8664 requires libmarblewidget.so.20()(64bit), but none of the providers can be installed. package nepomuk-core-4.14.3-1.fc21.x8664 requires libbaloofiles.so.4()(64bit), but none of the providers can be installed. package tiled-plugin-tmw-0.13.1-1.fc21.x8664 requires tiled = 0.13.1-1.fc21, but none of the providers can be installed. package nepomuk-core-libs-4.14.3-1.fc21.x8664 requires nepomuk-core = 4.14.3-1.fc21, but none of the providers can be installed. package libkdcraw-14.12.3-1.fc21.x8664 requires librawr.so.10()(64bit), but none of the providers can be installed. package nepomuk-widgets-4.14.3-1.fc21.x8664 requires libnepomukcore.so.4()(64bit), but none of the providers can be installed. package perl-PlRPC-0.2020-15.fc20.noarch requires perl(:MODULECOMPAT5.18.0), but none of the providers can be installed. package fedora-upgrade-28.1-2.fc28.noarch requires dnf-utils, but none of the providers can be installed

Honestly I have no idea what this means but also not what I was doing earlier in that process. Hoping for some support (English or German - system language is English).

Thank you in advance.

Regards, André

edit retag flag offensive close merge delete

Comments

Did you tried to do an update through the software app?

Gaurav29 gravatar imageGaurav29 ( 2018-05-19 13:40:24 -0600 )edit

You're trying to jump 7 releases in one upgrade, but it's not recommended to skip more than one. At this point, it would probably be both faster and safer to back up your data, do a clean installation and restore your backup.

sideburns gravatar imagesideburns ( 2018-05-19 18:17:58 -0600 )edit

Thank you for your replies. If that's the case then I prefer upgrading for the next release or, if I understand correctly, I can go 21 -> 23, not skipping more than one. Well... at least I tried, I'm stuck again and I fail to find the solution for it, or what it means:

(maximum comment lenght)

andre-1902 gravatar imageandre-1902 ( 2018-05-20 12:14:55 -0600 )edit

[Andre@noname ~]$ dnf --releasever=23 --setopt=deltarpm=false distro-sync Fedora 23 - x8664 5.0 MB/s | 43 MB 00:08
Fedora 23 - x86
64 - Updates 4.8 MB/s | 25 MB 00:05
Using metadata from Sun May 20 19:06:09 2018 (0:00:54 hours old) Error: package perl-PlRPC-0.2020-15.fc20.noarch requires perl(:MODULECOMPAT5.18.0), but none of the providers can be installed

andre-1902 gravatar imageandre-1902 ( 2018-05-20 12:15:16 -0600 )edit

Did you tried from the software app? Maybe that can work

Gaurav29 gravatar imageGaurav29 ( 2018-05-20 13:30:46 -0600 )edit