No sound in Fedora 27 & pulseaudio

asked 2018-03-26 12:11:29 -0600

krismath gravatar image

updated 2018-03-26 14:29:59 -0600

I have been trying multiple ways to restore my audio. pulseaudio had been working fine until I tried to update it. After that, the audio wasn't playing! I tested using speaker-test; no sounds were played. I tried opening a YouTube video on firefox; no sounds were played. I tried pulseaudio -k, pulseaudio --kill, pulseaudio -D and pulseaudio --start; none worked. I tried installing pavucontrol but it didn't help. Please help me!

Here is my Fedora (27) version output:

$ lsb_release -a
LSB Version:    :core-4.1-amd64:core-4.1-noarch:cxx-4.1-amd64:cxx-4.1-noarch:desktop-4.1-amd64:desktop-4.1-noarch:languages-4.1-amd64:languages-4.1-noarch:printing-4.1-amd64:printing-4.1-noarch
Distributor ID: Fedora
Description:    Fedora release 27 (Twenty Seven)
Release:    27
Codename:   TwentySeven

Here is my Linux kernel version

$ uname -a
Linux xxx 4.15.10-300.fc27.x86_64 #1 SMP Thu Mar 15 17:13:04 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Here is the output of pulseaudio -vvv

$ pulseaudio -vvv
I: [pulseaudio] main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
I: [pulseaudio] main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
D: [pulseaudio] core-rtclock.c: Timer slack is set to 50 us.
D: [pulseaudio] core-util.c: RealtimeKit worked.
I: [pulseaudio] core-util.c: Successfully gained nice level -11.
I: [pulseaudio] main.c: This is PulseAudio 11.1-rebootstrapped
D: [pulseaudio] main.c: Compilation host: x86_64-redhat-linux-gnu
D: [pulseaudio] main.c: Compilation CFLAGS: -O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -m64 -mtune=generic -fasynchronous-unwind-tables -W -Wextra -Wno-long-long -Wno-overlength-strings -Wunsafe-loop-optimizations -Wundef -Wformat=2 -Wlogical-op -Wsign-compare -Wformat-security -Wmissing-include-dirs -Wformat-nonliteral -Wpointer-arith -Winit-self -Wdeclaration-after-statement -Wfloat-equal -Wmissing-prototypes -Wredundant-decls -Wmissing-declarations -Wmissing-noreturn -Wshadow -Wendif-labels -Wcast-align -Wstrict-aliasing -Wwrite-strings -Wno-unused-parameter -ffast-math -fno-common -fdiagnostics-show-option -fdiagnostics-color=auto
D: [pulseaudio] main.c: Running on host: Linux x86_64 4.15.10-300.fc27.x86_64 #1 SMP Thu Mar 15 17:13:04 UTC 2018
D: [pulseaudio] main.c: Found 8 CPUs.
I: [pulseaudio] main.c: Page size is 4096 bytes
D: [pulseaudio] main.c: Compiled with Valgrind support: no
D: [pulseaudio] main.c: Running in valgrind mode: no
D: [pulseaudio] main.c: Running in VM: no
D: [pulseaudio] main.c: Optimized build: yes
D: [pulseaudio] main.c: FASTPATH defined, only fast path asserts disabled.
I: [pulseaudio] main.c: Machine ID is 1a9846e601564159a8918b6e46baff42.
I: [pulseaudio] main.c: Session ID is 3.
I: [pulseaudio] main.c: Using runtime directory /run/user/1000/pulse.
I: [pulseaudio] main.c: Using state directory /home/kris/.pulse.
I: [pulseaudio] main.c: Using modules directory /usr/lib64/pulse-11.1/modules.
I: [pulseaudio] main.c: Running in system mode: no
E: [pulseaudio] pid.c: Daemon already running.
E: [pulseaudio] main.c: pa_pid_file_create() failed.

Here is the output of speaker-test

$ speaker-test 

speaker-test 1.1.5

Playback device is default
Stream parameters are 48000Hz, S16_LE, 1 channels
Using 16 octaves of pink noise
Playback open error: -16,Device or resource busy

Here is the output of lspci

$ lspci | grep [Aa]udio
00:1f.3 Audio device: Intel Corporation CM238 HD Audio Controller (rev 31)

Here ... (more)

edit retag flag offensive close merge delete

Comments

What is the output of pactl info? It would be more useful to see the output of pulseaudio -vvv when there isn't another one running already. Another useful output would be pactl list, but the output of that is probably too large to post here and could potentially have private information. If you're ok with the information, you could use fpaste to post it.

ssieb gravatar imagessieb ( 2018-03-26 13:27:50 -0600 )edit

@Samuel Sleb I have added the output of pactl info and pactl list to my question.

krismath gravatar imagekrismath ( 2018-03-26 14:30:50 -0600 )edit

When you change the volume using the gnome-shell menu, do you hear the pop?

I would suggest removing the config files from ~/.pulse and ~/.config/pulse and see if that makes a difference. If it's still not working, then kill pulseaudio and run pulseaudio -vvv in a terminal and see if there are any useful messages there. You have to be quick to get it started before it's autostarted by something else.

ssieb gravatar imagessieb ( 2018-03-26 18:12:36 -0600 )edit

Thanks, I will try that. However, my Fedora installation is down right now. I will have to try that later.

krismath gravatar imagekrismath ( 2018-03-27 00:42:53 -0600 )edit