Cannot establish SSH with GPG-agent

asked 2018-03-26 06:13:14 -0600

romaf gravatar image

I've got a problem to connect via SSH to remote server using GPG-agent. I was trying with ~/.gnupg/gpg-agent.conf changed by adding "enable-ssh-support" and "write-env-file" and some other tricks I found in the Web, but nothing helped. I can use my GPG smartcards (normal card and Yubikey) for standard tasks ex. encrypting/decrypting, signing, certify (files and emails) but cannot to authenticate SSH connection: "Permission denied (publickey)."

I can authenticate SSH only in Putty in Windows (Gpg4Win).

Can somebody help?

edit retag flag offensive close merge delete