Ask Your Question
0

hotkeys are not recognized by xev

asked 2018-03-06 06:20:38 -0500

Hi,

I just bought a Dell XPS 13 developer edition that came with Ubuntu. I flashed it with Fedora right away and I noticed that the hotkeys (F1 to F12) are not working by default, one needs to press Fn key to get the F1 behavior but pressing F1 (mute in my case) does nothing.

xev does not show any keycode either, so I'm at a loss on how to investigate further. Any suggestions?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-03-06 18:10:42 -0500

ssieb gravatar image

The requirement to press Fn to get actual function keys is typical with laptops now. You can maybe change that setting in the BIOS or apparently on Dell laptops, Fn-ESC will toggle that.

As to the multimedia keys not working, what does lsmod | grep dell give you? Try switching to a console with CTRL-ALT-F3 (maybe add an Fn if that doesn't work). Login there and run showkey -s. Press some of the keys and see if you get anything. The program will exit if you don't press anything for 10 secs. ALT-F2 or maybe ALT-F1 (again, possibly with the Fn key as well) to get back to your desktop.

After pressing some of those keys, check in the journal using sudo journalctl -r and see if there are any messages about unknown keys.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2018-03-06 06:20:38 -0500

Seen: 73 times

Last updated: Mar 06 '18