Ask Your Question
0

dnf problem: cannot install both - conflicting requests

asked 2018-03-04 16:04:21 -0600

lewatoto gravatar image
Fedora 27 Gnome 3.26.2
4.14.14-300.fc27.x86_64

I was updating the system when there was a power outage, when I tried to update again I get these errors:

Running transaction check
Transaction check succeeded.
Running transaction test
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Error: Transaction check error:
  file /usr/share/gcc-7/python/libstdcxx/v6/__pycache__/printers.cpython-36.opt-1.pyc from install of libstdc++-7.3.1-2.fc27.i686 conflicts with file from package libstdc++-7.2.1-2.fc27.x86_64
  file /usr/share/gcc-7/python/libstdcxx/v6/__pycache__/printers.cpython-36.pyc from install of libstdc++-7.3.1-2.fc27.i686 conflicts with file from package libstdc++-7.2.1-2.fc27.x86_64
  file /usr/share/gcc-7/python/libstdcxx/v6/printers.py from install of libstdc++-7.3.1-2.fc27.i686 conflicts with file from package libstdc++-7.2.1-2.fc27.x86_64
  file /usr/share/gcc-7/python/libstdcxx/v6/printers.pyc from install of libstdc++-7.3.1-2.fc27.i686 conflicts with file from package libstdc++-7.2.1-2.fc27.x86_64
  file /usr/share/gcc-7/python/libstdcxx/v6/printers.pyo from install of libstdc++-7.3.1-2.fc27.i686 conflicts with file from package libstdc++-7.2.1-2.fc27.x86_64
  file /usr/share/doc/gnutls/NEWS from install of gnutls-3.5.18-2.fc27.i686 conflicts with file from package gnutls-3.5.17-1.fc27.x86_64
  file /usr/share/locale/cs/LC_MESSAGES/gnutls.mo from install of gnutls-3.5.18-2.fc27.i686 conflicts with file from package gnutls-3.5.17-1.fc27.x86_64
  file /usr/share/locale/de/LC_MESSAGES/gnutls.mo from install of gnutls-3.5.18-2.fc27.i686 conflicts with file from package gnutls-3.5.17-1.fc27.x86_64
  file /usr/share/locale/en@boldquot/LC_MESSAGES/gnutls.mo from install of gnutls-3.5.18-2.fc27.i686 conflicts with file from package gnutls-3.5.17-1.fc27.x86_64
  file /usr/share/locale/en@quot/LC_MESSAGES/gnutls.mo from install of gnutls-3.5.18-2.fc27.i686 conflicts with file from package gnutls-3.5.17-1.fc27.x86_64
  file /usr/share/locale/eo/LC_MESSAGES/gnutls.mo from install of gnutls-3.5.18-2.fc27.i686 conflicts with file from package gnutls-3.5.17-1.fc27.x86_64
  file /usr/share/locale/fi/LC_MESSAGES/gnutls.mo from install of gnutls-3.5.18-2.fc27.i686 conflicts with file from package gnutls-3.5.17-1.fc27.x86_64
  file /usr/share/locale/fr/LC_MESSAGES/gnutls.mo from install of gnutls-3.5.18-2.fc27.i686 conflicts with file from package gnutls-3.5.17-1.fc27.x86_64
  file /usr/share/locale/it/LC_MESSAGES/gnutls.mo from install of gnutls-3.5.18-2.fc27.i686 conflicts with file from package gnutls-3.5.17-1.fc27.x86_64
  file /usr/share/locale/ms/LC_MESSAGES/gnutls.mo from install of gnutls-3.5.18-2.fc27.i686 conflicts with file from package gnutls-3.5.17-1.fc27.x86_64
  file /usr/share/locale/nl/LC_MESSAGES/gnutls.mo from install of gnutls-3.5.18-2.fc27.i686 conflicts with file from package gnutls-3.5 ...
(more)
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-03-04 17:54:10 -0600

fcomida gravatar image

dnf upgrade --best --allowerasing

edit flag offensive delete link more

Comments

still not working same error

lewatoto gravatar imagelewatoto ( 2018-03-04 20:07:06 -0600 )edit

Use rpm -e --nodeps gnutls-3.5.18-2.fc27.i686 for forcing removing the offending package, update the system and install it again.

fcomida gravatar imagefcomida ( 2018-03-05 03:55:42 -0600 )edit

worked but I had to remove the packages:

pcre2-10.30-5.fc27.x86_64
gnutls-3.5.17-1.fc27.x86_64

and then updated normally, thanks

lewatoto gravatar imagelewatoto ( 2018-03-06 18:32:33 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2018-03-04 15:49:32 -0600

Seen: 1,386 times

Last updated: Mar 04 '18