Ask Your Question
0

Graphics card problems (i guess)

asked 2018-03-03 00:21:31 -0500

KemyKo gravatar image

updated 2018-03-06 00:34:31 -0500

Once i installed my graphics card my computer starts acting weird. ( https://rpmfusion.org/Howto/NVIDIA#In...thedrivers) i have a GeForce GTX 950M. I have fedora 27 with KDE Plasma

When i boot up my computer i cannot see the lock screen. But if i type my password correctly i am greeted with the desktop in 1 min. This didn`t happen before.

I also noticed that all of the top bars are now smaller.

OBS Recorder doesn`t seem to like my GPU. When i open it it says that my GPU is not supported or needs an update.

I really need some help. I want to fix at least the black screen problem.

i just noticed that the kdm folder is empty. any suggestions to why that happens exactly when i install the nvidia driver

-----copy/paste from comments section

yes, i just tried it now. in adition to what i found in the wiki i installed nvidia-settings from the same repo. it was not there by default. when i run codeblocks with optirun -b prime, in the nvidia-settings panel i do not see any changes. i do not think it is using the nvidia card. in addition to that, the nvidia settings panel shows 0 at the screen number label and by default the virtual display is set to smth very small 640x480 pixels (217x163 millimeters). pressing on autodetect displays won`t do anything.

i tried to do optirun glxgears and the difference in fps is huge. so the card must be working. but the nvidia-settingss thing is not showing anything. is that a huge problem?


At this point i think that the question is answered, i no longer have any problems with the nvidia card. I may need some information regarding the optimus and prime commands usage.

edit retag flag offensive close merge delete

Comments

do you have an integrated intel GPU also and can you disable it in BIOS? you could try to add 'nomodeset' to the kernel command line for testing..

becks21 gravatar imagebecks21 ( 2018-03-03 11:06:55 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2018-03-03 14:22:18 -0500

ozeszty gravatar image

For newer laptops with Nvidia GPUs, if you want to use both integrated and dedicated GPUs, it's better to install Bumblebee. In that case you should remove driver installed from RPMFusion and follow instructions from linked wiki. It describes how to install drivers and switch between GPUs.

Depending on your BIOS settings, you should be able to disable integrated GPU (RPMFusion Nvidia drivers will suffice then) or discrete GPU (in that case there's no need to install any additional drivers).

edit flag offensive delete link more

Comments

So i reinstalled fedora 27 with kde. And i installed the graphics driver from negativo17. i did the followings

sudo dnf config-manager --add-repo=https://negativo17.org/repos/fedora-nvidia.repo

sudo dnf install kernel-devel dkms dkms-nvidia nvidia-driver nvidia-settings vulkan.i686 nvidia-driver-libs.i686

sudo dkms autoinstall

And i run in the same problems stated before. I cannot see the screen when i type my password when i boot my computer. I have to blindly type the password and guess whether or not it`s correct. The card works properly tho.

KemyKo gravatar imageKemyKo ( 2018-03-05 08:39:25 -0500 )edit

i just noticed that the kdm folder is empty. any suggestions to why that happens exactly when i install the nvidia driver

KemyKo gravatar imageKemyKo ( 2018-03-05 13:20:34 -0500 )edit

so you did not follow the instructions to install bumblebee given in the link provided by ozeszty? did you try to add nomodeset to the kernel command line as I suggested?

becks21 gravatar imagebecks21 ( 2018-03-05 14:00:29 -0500 )edit

yes, i just tried it now. in adition to what i found in the wiki i installed nvidia-settings from the same repo. it was not there by default. when i run codeblocks with optirun -b prime, in the nvidia-settings panel i do not see any changes. i do not think it is using the nvidia card. in addition to that, the nvidia settings panel shows 0 at the screen number label and by default the virtual display is set to smth very small 640x480 pixels (217x163 millimeters). pressing on autodetect displays won`t do anything.

KemyKo gravatar imageKemyKo ( 2018-03-05 15:39:25 -0500 )edit

i tried to do optirun glxgears and the difference in fps is huge. so the card must be working. but the nvidia-settingss thing is not showing anything. is that a huge problem

KemyKo gravatar imageKemyKo ( 2018-03-06 00:22:12 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2018-03-03 00:21:31 -0500

Seen: 580 times

Last updated: Mar 06 '18