Enable splecial windows key on fedora 27 + Desktop Behaviour -> Screen edges

asked 2018-03-02 11:18:10 -0600

KemyKo gravatar image

updated 2018-03-05 13:20:18 -0600

IMPORTANT : I RUN THE KDE VERSION OF FEDORA 27

As my question says i want my left windows key to trigger the application menu.

The thing is that it used to work, A few hours ago i messed around with panels and widgets and i deleted my application launcher widget. Once i reassigned it to its original position the windows key stopped triggering the application menu. And so did the screen edge thing. They no longer trigger the menu. (The button works though).

I tried to play around with the options and search for possible solutions but nothing worked. (i did reboot my computer as well :) ).

Sorry for this stupid question but i can`t figure it out by myself :))).

edit retag flag offensive close merge delete

Comments

I kind of solved my issue but i still want to clarify some things because i don`t know why it works. I went to global shortcuts and on the plasma tab i had the "Activation Application dashboard" set to nothing. I want it to be triggered on the windows key, but i had to type a combination of keys as input. I pressed on {win} + {enter}. For some reason this works as i expect it to. It triggers my application menu without pressing enter. Why?

KemyKo gravatar imageKemyKo ( 2018-03-02 11:22:56 -0600 )edit

KDE only very recently added support for single-key shortcuts. It has been a problem with KDE for years and years.

Aeyoun gravatar imageAeyoun ( 2018-03-02 17:37:21 -0600 )edit