Ask Your Question
3

Upgraded to Fedora 27 - is dog slow + issues - what to do?

asked 2018-02-18 04:36:10 -0600

updated 2018-02-21 03:36:40 -0600

I have just completed upgrading from F23 to F27 (via F25) and it is dog slow everywhere. F23 was fine. I already have swap on SSD and it is not being touched anyway according to CONKY. On F23 swap used to be used regularly. I don't know if F27 is an SSD build but, there must be something that can be done? It seems to be HDD waits. As I am typing this form letters are being skipped, some letters are repeated and I have to go back and edit everything I type carefully. Sometimes whole bunches of letters are missed then the rest pop in out of nowhere.

Nautilus took LITERALLY HOURS to open. I had given up then later boom four nautilus windows open all at once.

The keyboard shortcuts on nyx are not working. I press right-arrow and instead of switching pane, it says this will clear the log press c again to confirm.

That, and I have been robbed of my task tray by Gnome. Fortunately, F27 has topicons-plus in the updates repo.

What to do? How to make F27 usable?

EDIT 1: Attached output of journalctl -b --> here <--

Every time the cursor locks in position the HDD light is flashing madly. When I let it st everything seems to settle but as soon as I do something, bam! Even on the lock screen. Commands like DNF or whatever take forever to execute. Much longer than before with the HDD light going crazy the whole time.

EDIT 2: Everything is a bit more responsive with Firefox closed, but I would not say that the issue is resolved.Firefox never made any issue this bad before - I have the same tab sets. Sorted nyx - uninstalled the up-to-date pip version I carried forward from F23 and installed from the Fedora repo, it wasn't available here on F23. Nautilus now opens without waiting hours, must have been very shy the first time. SWAP is being used if I get enough things running according to CONKY.

EDIT 3: Using iotop I can see that it is mostly bitcoin-qt making the io's very busy, with it quit the system seems mostly normal. Sepcifically, the threads are identified as bitcoin-qt [bitcoin-loadblk] for extended periods during startup and, bitcoin-qt [bitcoin-msghand] after it is up and running until syncroization is complete and all outgoing connections are made. After that, everything sems normal. This was not an issue on F23.

Question remains, what to do to make this usable - it was not an issue under F23?

edit retag flag offensive close merge delete

Comments

Hi! Welcome to AskFedora!

Well, the first thing would be to see what's eating all the IO/CPU cycles to slow your system down. Please look at the output of journalctl -b to begin with and see what it says. An update from F23 to F27, even if via F25 is quite a large one. Lots of things have changed between F23 and F27, and this includes user configurations. I'd also suggest you create a fresh user to see if the issue persists there too.

PS: The nyx issue should be asked as a separate question. Probably a configuration change in nyx.

FranciscoD_ gravatar imageFranciscoD_ ( 2018-02-18 06:39:43 -0600 )edit

@FranciscoD_ Thanks. I will get back to nyx after. I might try uninstalling the pip version I have and see if it is in a Fedora repo. journalctl -b will be attached as soon as it finished uploading.

Willtech gravatar imageWilltech ( 2018-02-19 02:23:31 -0600 )edit
1

Can you try looking at the output of iotop? It might give us a hint which process is doing a lot of I/O.

Does the system behave the same way when you boot it without a graphical user interface?

fringmar gravatar imagefringmar ( 2018-02-19 16:38:47 -0600 )edit

Your logs show constant errors and crashes from gnome-shell. Can you create a new user and see how gnome-shell works without any extensions and fresh configs?

FranciscoD_ gravatar imageFranciscoD_ ( 2018-02-20 03:48:33 -0600 )edit

@fringmar good call on iotop, I hadn't seen it before.

Willtech gravatar imageWilltech ( 2018-02-20 04:06:16 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-02-23 19:15:13 -0600

This situation seems much improved after running upgrade again and getting kernel-4.15.4 and Bitcoin Core v0.16rc4. Perhaps it is one or both responsible for the improvement. Running DNF commands now has more impact on system performance than running bitcoin-qt.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2018-02-18 04:36:10 -0600

Seen: 954 times

Last updated: Feb 23 '18