Ask Your Question
0

Replace default sound manager in settings?

asked 2018-02-14 12:49:18 -0600

piperman123 gravatar image

updated 2018-02-15 16:28:39 -0600

I'm having some trouble with the sound settings in fedora where if I change my audio device from the sound applet in the top right or from the settings menu my audio device will default back to 'Digital Stereo (IEC958) Output + Analog Stereo' (and I have to go back into pavucontrol and change the profile back to 'Analog Surround 5.1 Output + Analog Stereo' in order to get sound back. Is there a way to fix this? I've tried running sudo dnf reinstall "pusle" and ..."alsa and reinstalling all of those. I'm using ax370-gaming 5 mobo which has dual ALC1220 chips and pulse and alsa seem to be detecting them correctly. I've noticed there's been a patch added into the kernel a while ago. I'm on kernel 4.14.18-300.fc27.x86_64, Fedora 27. Everything is updated. If the output of "pactl list" or "aplay -l" let me know,

Please let me know if there is a tidier way of doing this:

pactl list (only including parts that may be relevant):

Card #1
    Name: alsa_card.pci-0000_0d_00.3
    Driver: module-alsa-card.c
    Owner Module: 7
    Properties:
        alsa.card = "1"
        alsa.card_name = "HD-Audio Generic"
        alsa.long_card_name = "HDAudio-Gigabyte-ALC1220DualCodecs"
        alsa.driver_name = "snd_hda_intel"
        device.bus_path = "pci-0000:0d:00.3"
        sysfs.path = "/devices/pci0000:00/0000:00:08.1/0000:0d:00.3/sound/card1"
        device.bus = "pci"
        device.vendor.id = "1022"
        device.vendor.name = "Advanced Micro Devices, Inc. [AMD]"
        device.product.id = "1457"
        device.string = "1"
        device.description = "HD-Audio Generic"
        module-udev-detect.discovered = "1"
        device.icon_name = "audio-card-pci"
    Profiles:
        input:analog-stereo: Analog Stereo Input (sinks: 0, sources: 1, priority: 65, available: yes)
        output:analog-stereo: Analog Stereo Output (sinks: 1, sources: 0, priority: 6500, available: no)
        output:analog-stereo+input:analog-stereo: Analog Stereo Duplex (sinks: 1, sources: 1, priority: 6565, available: yes)
        output:analog-surround-21: Analog Surround 2.1 Output (sinks: 1, sources: 0, priority: 1300, available: no)
        output:analog-surround-21+input:analog-stereo: Analog Surround 2.1 Output + Analog Stereo Input (sinks: 1, sources: 1, priority: 1365, available: yes)
        output:analog-surround-40: Analog Surround 4.0 Output (sinks: 1, sources: 0, priority: 1200, available: no)
        output:analog-surround-40+input:analog-stereo: Analog Surround 4.0 Output + Analog Stereo Input (sinks: 1, sources: 1, priority: 1265, available: yes)
        output:analog-surround-41: Analog Surround 4.1 Output (sinks: 1, sources: 0, priority: 1300, available: no)
        output:analog-surround-41+input:analog-stereo: Analog Surround 4.1 Output + Analog Stereo Input (sinks: 1, sources: 1, priority: 1365, available: yes)
        output:analog-surround-50: Analog Surround 5.0 Output (sinks: 1, sources: 0, priority: 1200, available: no)
        output:analog-surround-50+input:analog-stereo: Analog Surround 5.0 Output + Analog Stereo Input (sinks: 1, sources: 1, priority: 1265, available: yes)
        output:analog-surround-51: Analog Surround 5.1 Output (sinks: 1, sources: 0, priority: 1300, available: no)
        output:analog-surround-51+input:analog-stereo: Analog Surround 5.1 Output + Analog Stereo Input (sinks: 1, sources: 1, priority: 1365, available: yes)
        output:iec958-stereo: Digital Stereo (IEC958) Output (sinks: 1, sources: 0, priority: 5500, available: yes)
        output:iec958-stereo+input:analog-stereo: Digital Stereo (IEC958) Output + Analog Stereo Input (sinks: 1 ...
(more)
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-02-14 15:31:30 -0600

kainblock gravatar image

It seems like you don't change some values on /etc/pulse/daemon.conf

so open terminal and choose an editor (vi , vim, gedit etc) and type :

sudo gedit  /etc/pulse/daemon.conf

add this lines in file:

default-sample-channels = 6 

enable-lfe-remixing = yes

save and restart again

edit flag offensive delete link more

Comments

Thanks for the reply. I added the changes you mentioned and also noticed:

default-channel-map = front-left,front-right

I thought it would change automatically with those changes but it didn't so I changed it to:

default-channel-map = front-left,front-right,rear-left,rear-right,front-center,lfe

But this didn't work either. Trying to edit anything related to that device outside of pavucontrol results in it resetting to "Digital Stereo (IEC958) Output + Analog Stereo". That is also the only option available in the gnome sound settings. It's only through pavucontrol I can get 5.1.

piperman123 gravatar imagepiperman123 ( 2018-02-15 15:49:36 -0600 )edit

...which obviously means I can't adjust my volume or anything normally.

piperman123 gravatar imagepiperman123 ( 2018-02-15 15:50:36 -0600 )edit

Return the outputs of those 2 commands

cat /etc/pulse/daemon.conf | grep -v '^$\|^\s#\|;' cat ~/.config/pulse/daemon.conf | grep -v '^$\|^\s#\|;'

kainblock gravatar imagekainblock ( 2018-02-24 06:38:01 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2018-02-14 12:49:18 -0600

Seen: 742 times

Last updated: Feb 15 '18