Installing CUDA on Fedora26

asked 2018-01-31 07:03:38 -0600

fcs gravatar image

Hi,

I am having some issues installing negativo17 Nvidia driver on Fedora26, I followed this https://negativo17.org/nvidia-driver/ and installed nvidia-driver and later nvidia-driver-cuda, but I am getting some errors on the startup:

On /var/boot.log:

(1 of 2) A start job is running for Builds and install new kmods from akmod packages (13s / no limit ... Starting Fallback to nouveau as nvidia did not load...

And on /var/log/nvidia-installer.log:

nvidia-installer log file '/var/log/nvidia-installer.log' creation time: Fri Dec 1 16:49:27 2017 installer version: 384.81

PATH: /sbin:/bin:/usr/sbin:/usr/bin

nvidia-installer command line: ./nvidia-installer --ui=none --no-questions --accept-license --disable-nouveau --run-nvidia-xconfig

Using built-in stream user interface -> Detected 4 CPUs online; setting concurrency level to 4. -> The file '/tmp/.X0-lock' exists and appears to contain the process ID '32110' of a runnning X server. ERROR: You appear to be running an X server; please exit X before installing. For further details, please see the section INSTALLING THE NVIDIA DRIVER in the README available on the Linux driver download page at www.nvidia.com . ERROR: Installation has failed. Please see the file '/var/log/nvidia-installer.log' for details. You may find suggestions on fixing installation problems in the README available on the Linux driver download page at www.nvidia.com .

Any ideas on what I am doing wrong?

edit retag flag offensive close merge delete