Main screen does not go to sleep after pressing Win+L, mouse pointer still appears

asked 2018-01-19 10:12:20 -0600

updated 2018-01-20 07:47:25 -0600

Hello,

I am currently using Fedora 27 with GNOME3 and I have a problem. I use my system with three displays, and unfortunately, when I press Win+L to lock my current session, my displays on the sides go to power saving mode properly, but my main display does not, therefore the mouse pointer still appears on the screen as this self-made video suggests. video on Vimeo

Is there any way to solve this problem?

My setup:

  • MB: ASUS M5A97 EVO R2.0
  • CPU: AMD FX 8320 @ stock
  • CPU Cooler: Alpenföhn Brocken 2+Thermalright TY-147
  • RAM: 4x8G 1600MHz Corsair CMV8GX3M1A1600C11 RAM
  • VGA: Gigabyte GeForce GTX 960 GV-N960WF2OC-4GD 4GB (currently using negativo17's repo, but the problem persisted with the latest driver from the site of nvidia)
  • SSD: Samsung 830 128 GB
  • SSD: Samsung 850 EVO 256GB
  • HDD: Samsung 1TB 7200rpm SATAII
  • HDD: SEAGATE 2TB 7200rpm SATAIII
  • HDD: Toshiba 3TB 7200rpm SATAIII
  • Sound Card: ASUS Xonar DS
  • OPAMP: TI OPA2604AP
  • PSU: EVGA SuperNOVA 850 G2 850W (220-G2-0850-XR)
  • Case: Corsair Carbide 300R
  • Sound System: Edifier Multimedia HCS2330 C2 Plus 2.1 System
  • Mouse: Logitech G400
  • Display: Dell U2211H
  • Display: Dell P2214H
  • Display: Dell P2217H

Thanks!

edit retag flag offensive close merge delete

Comments

Hmm, I though Super-L only locked the screen. A Google search turns up people complaining about the opposite problem, in that the display turns off on lock rather than displaying a lock screen.

Mordoc gravatar imageMordoc ( 2018-01-20 15:16:24 -0600 )edit

Hello,

Thanks for your answer. Since I posted my question, I was continuously searching for a solution. As some pointed out (in an FB group) I had forgotten to share some crucial information, namely the type of connection between displays. The two on the sides are connected via DVI, and my main display (where I experienced the error described) is connected via DP, and since DPMS is not implemented in the proprietary nVidia driver (what can cause the same syptoms), as a suggestion I got the following to try: change the cable to HDMI where DPMS is also supported just as in the case of DVI.

Armand Bozsik gravatar imageArmand Bozsik ( 2018-01-21 10:54:57 -0600 )edit