Ask Your Question
2

Fedora LiveDVD ignores given boot options to setup keyboard layout

asked 2018-01-18 12:39:51 -0600

beta-tester gravatar image

updated 2018-01-19 12:54:41 -0600

when i boot Fedora 27 LiveDVD and modify the boot options to use an other keyboard layout and user interface language, those parameters are completely ignored.

1'st, boot the PC from an Fedora27 LiveDVD (Fedora-Workstation-Live-x86_64-27-1.6.iso)

2'nd, and modify the boot option in the boot menu by hitting [TAB]:

3'rd, add at the end

rd.vconsole.keymap=de-latin1-nodeadkeys

and

rd.locale.LANG=de_DE.utf8

as shown in the dracut man pages dracut - I18N.

but when Fedora is fully booted into the UI, the language is still "en_US" and the keyboard is "en" as well.

for the keyboard layout i also tried:

rd.vconsole.keymap=de
vconsole.keymap=de
keymap=de
inst.keymap=de

for the UI language similar:

rd.locale.LANG=de_DE
locale.LANG=de_DE
lang=de_DE
inst.lang=de_DE

all without success.

any idea, how i can change keyboard layout and UI language of Fedora LiveDVD via boot options?

edit retag flag offensive close merge delete

Comments

perhaps this is a bug? if nobody has a better idea it might be good to file a report with redhat bugzilla

noobusinghacks gravatar imagenoobusinghacks ( 2018-02-04 21:49:12 -0600 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2018-05-03 07:45:23 -0600

beta-tester gravatar image

the option vconsole.keymap=de-latin1-nodeadkeys does only affect the keyboard layout of the virtual console, but not the keyboard layout of the Desktop. are there any options i can set as boot parameter to let Fedora set up the Desktop to german keyboard layout as well?

edit flag offensive delete link more
0

answered 2018-02-04 07:18:23 -0600

beta-tester gravatar image

nobody here, who can help me to give me the right boot options to setup the keyboard layout to german QWERTZ ?

edit flag offensive delete link more

Comments

1

I'm guessing boot settings are for the virtual consoles and/or are overwritten by the DE. Switch to a virtual console and see if you have german layout there.

fcomida gravatar imagefcomida ( 2018-02-04 08:07:07 -0600 )edit

just tried Fedora 28 Desktop. yes, it seems to be options for the virtual console only. with option vconsole.keymap=de-latin1-nodeadkeys the keyboard layout it set to german on the console. but not for the Desktop and its terminal there. the strange thing is even i set that vconsole option, when i take a look to /etc/vconsole.conf or /etc/locale.conf there is still english settings included. the man pages is mentioned, that the option will affect those files. the option locale.LANG=de_DE.utf8 does not appear anywhere. not in any file, not in any settings, not in any behavior

beta-tester gravatar imagebeta-tester ( 2018-05-03 07:40:46 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2018-01-18 12:39:51 -0600

Seen: 147 times

Last updated: May 03 '18