How to enable wayland support for new nvidia driver

asked 2018-01-14 12:35:10 -0600

rustyraptor gravatar image

I just installed Nvidia's latest driver. NVIDIA 390.12. According to the changelong it has libnvidia-egl-wayland and I can actually see the file when I extract from the installer. Previously it wasn't enabled. However GNOME is still logging into X11 automatically. Do I need to place the new lib somewhere for it to work? I would really love to try wayland with nvidia now.

I still get this when I try to start wayland manually with:

dbus-run-session -- gnome-shell --display-server --wayland

(gnome-shell:5150): mutter-WARNING **: Cant initialize KMS backend: Could not get session ID: No such file or directory

I haven't seen any discussion about getting it working yet probably because it's really new (Jan 4th)

    System:    Host: localhost.localdomain Kernel: 4.14.13-300.fc27.x86_64 x86_64 bits: 64 gcc: 7.2.1
           Desktop: Gnome 3.26.2 Distro: Fedora release 27 (Twenty Seven)
Machine:   Device: desktop System: Gigabyte product: N/A serial: N/A
           Mobo: Gigabyte model: H110M-A-CF v: x.x serial: N/A UEFI: American Megatrends v: F5 date: 03/07/2016
CPU:       Quad core Intel Core i5-6500 (-MCP-) arch: Skylake-S rev.3 cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 25536
           clock speeds: max: 3600 MHz 1: 1135 MHz 2: 3235 MHz 3: 3038 MHz 4: 3324 MHz
Graphics:  Card: NVIDIA GP106 [GeForce GTX 1060 6GB] bus-ID: 01:00.0
           Display Server: x11 (X.org 119.6 ) driver: nvidia Resolution: 1680x1050@59.88hz
           OpenGL: renderer: GeForce GTX 1060 6GB/PCIe/SSE2 version: 4.6.0 NVIDIA 390.12 Direct Render: Yes
Audio:     Card-1 NVIDIA GP106 High Definition Audio Controller driver: snd_hda_intel bus-ID: 01:00.1
           Card-2 Intel Sunrise Point-H HD Audio driver: snd_hda_intel bus-ID: 00:1f.3
           Sound: Advanced Linux Sound Architecture v: k4.14.13-300.fc27.x86_64
Network:   Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: d000 bus-ID: 02:00.0
           IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 2240.5GB (1.7% used)
           ID-1: /dev/sda model: ST2000DM001 size: 2000.4GB
           ID-2: /dev/sdb model: AVSSDS3E100Z size: 240.1GB
Partition: ID-1: / size: 49G used: 9.5G (21%) fs: ext4 dev: /dev/dm-0
           ID-2: /boot size: 976M used: 180M (20%) fs: ext4 dev: /dev/sda2
           ID-3: /home size: 1.8T used: 18G (2%) fs: ext4 dev: /dev/dm-2
           ID-4: swap-1 size: 8.46GB used: 0.00GB (0%) fs: swap dev: /dev/dm-1
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 40.5C mobo: 29.8C gpu: 1.0:30C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 248 Uptime: 11 min Memory: 2117.3/7931.4MB Init: systemd runlevel: 5 Gcc sys: 7.2.1
           Client: Shell (bash 4.4.121) inxi: 2.3.53
edit retag flag offensive close merge delete

Comments

I can confirm this issue. Similar output here. Any update?

(mutter:8998): mutter-WARNING **: 17:04:59.340: Can't initialize KMS backend: Could not get session ID: No such file or directory

Graphics: Device-1: Intel Skylake GT2 [HD Graphics 520] driver: i915 v: kernel Device-2: NVIDIA GM107M [GeForce GTX 950M] driver: nvidia v: 396.45 Display: wayland server: Fedora Project X.org 11.0 driver: modesetting,nvidia unloaded: nouveau resolution: 1920x1080~60Hz OpenGL: renderer: Mesa DRI Intel HD Graphics 520 (Skylake GT2) v: 4.5 Mesa 18.0.5

Jeff Shee gravatar imageJeff Shee ( 2018-09-08 03:07:41 -0600 )edit