Suddenly no sound in Fedora 27

asked 2018-01-14 06:32:18 -0600

Kakao gravatar image

i had working sound in Fedora 27 and after some of the last updates it stopped working.

Starting amarok I receive this notification:

the audio playback device HDA Intel PCH (AL887-VD Analog) does not work

and these error messages:

$ amarok
AL lib: (WW) alc_initconfig: Failed to initialize backend "pulse"
AL lib: (EE) ALCplaybackAlsa_open: Could not open playback device 'default': Connection refused
AL lib: (WW) alcSetError: Error generated on device (nil), code 0xa005

How to debug? I tried a previous kernel with no success.

alsa-info.txt:

upload=true&script=true&cardinfo=
!!################################
!!ALSA Information Script v 0.4.64
!!################################

!!Script ran on: Sun Jan 14 11:28:57 UTC 2018


!!Linux Distribution
!!------------------

Fedora release 27 (Twenty Seven) NAME=Fedora ID=fedora PRETTY_NAME="Fedora 27 (Twenty Seven)" CPE_NAME="cpe:/o:fedoraproject:fedora:27" HOME_URL="https://fedoraproject.org/" SUPPORT_URL="https://fedoraproject.org/wiki/Communicating_and_getting_help" BUG_REPORT_URL="https://bugzilla.redhat.com/" REDHAT_BUGZILLA_PRODUCT="Fedora" REDHAT_BUGZILLA_PRODUCT_VERSION=27 REDHAT_SUPPORT_PRODUCT="Fedora" REDHAT_SUPPORT_PRODUCT_VERSION=27 PRIVACY_POLICY_URL="https://fedoraproject.org/wiki/Legal:PrivacyPolicy" Fedora release 27 (Twenty Seven) Fedora release 27 (Twenty Seven)


!!DMI Information
!!---------------

Manufacturer:      System manufacturer
Product Name:      System Product Name
Product Version:   System Version
Firmware Version:  2203
Board Vendor:      ASUSTeK COMPUTER INC.
Board Name:        P8Z77-M


!!ACPI Device Status Information
!!---------------

/sys/bus/acpi/devices/INT3F0D:00/status      15
/sys/bus/acpi/devices/PNP0103:00/status      15
/sys/bus/acpi/devices/PNP0C01:00/status      15
/sys/bus/acpi/devices/PNP0C0C:00/status      11
/sys/bus/acpi/devices/PNP0C0F:00/status      9
/sys/bus/acpi/devices/PNP0C0F:01/status      9
/sys/bus/acpi/devices/PNP0C0F:02/status      9
/sys/bus/acpi/devices/PNP0C0F:03/status      9
/sys/bus/acpi/devices/PNP0C0F:04/status      9
/sys/bus/acpi/devices/PNP0C0F:05/status      9
/sys/bus/acpi/devices/PNP0C0F:06/status      9
/sys/bus/acpi/devices/PNP0C0F:07/status      9


!!Kernel Information
!!------------------

Kernel release:    4.14.13-300.fc27.x86_64
Operating System:  GNU/Linux
Architecture:      x86_64
Processor:         x86_64
SMP Enabled:       Yes


!!ALSA Version
!!------------

Driver version:     k4.14.13-300.fc27.x86_64
Library version:    
Utilities version:  1.1.5


!!Loaded ALSA modules
!!-------------------

snd_hda_intel
snd_hda_intel
snd_usb_audio


!!Sound Servers on this system
!!----------------------------

Pulseaudio:
    Installed - Yes (/usr/bin/pulseaudio)
    Running - Yes

Jack:
    Installed - Yes (/usr/bin/jackd)
    Running - No


!!Soundcards recognised by ALSA
!!-----------------------------

0 [PCH            ]: HDA-Intel - HDA Intel PCH
                    HDA Intel PCH at 0xf7110000 irq 29
1 [NVidia         ]: HDA-Intel - HDA NVidia
                    HDA NVidia at 0xf7080000 irq 17
2 [Device         ]: USB-Audio - USB Sound Device
                    USB Sound Device at usb-0000:00:1d.0-1.8, full speed


!!PCI Soundcards installed in the system
!!--------------------------------------

00:1b.0 Audio device: Intel Corporation 7 Series/C216 Chipset Family High Definition Audio Controller (rev 04)
01:00.1 Audio device: NVIDIA Corporation GK208 HDMI/DP Audio Controller (rev a1)


!!Advanced information - PCI Vendor/Device/Subsystem ID's
!!-------------------------------------------------------

00:1b.0 0403: 8086:1e20 (rev 04)
    Subsystem: 1043:84a8
--
01:00.1 0403: 10de:0e0f (rev a1)
    Subsystem: 1043:8501


!!Loaded sound module options
!!---------------------------

!!Module: snd_hda_intel
    align_buffer_size : -1
    bdl_pos_adj : -1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1 ...
(more)
edit retag flag offensive close merge delete