Ask Your Question
0

Fedora 27 Kde - boot time 48s - how do i reduce it?

asked 2018-01-12 22:54:43 -0600

Silvermystv7 gravatar image

Hi, I am using a lenovo laptop with i3 processor, 8GB ram, WD hardisk 5400 rpm, I recently switched to Fedora(5 days ago) and wanted to try Kde, since am switching from windows to linux, but i see very large boot time. I went online to find solutions, but being a newbie i wasnt able to go beyond the initial systemd-analyze blame. I got the output but am not sure of which services i can stop.

The following is the output of systemd-analyze

Startup finished in 1.916s (kernel) + 5.182s (initrd) + 41.070s (userspace) = 48.169s

This is the output of systemd-analyze blame

13.740s systemd-journal-flush.service
         10.613s lvm2-monitor.service
          9.413s sssd.service
          9.070s systemd-udev-settle.service
          8.245s dev-mapper-fedora\x2droot.device
          7.673s firewalld.service
          6.761s initrd-switch-root.service
          6.331s NetworkManager-wait-online.service
          5.400s ModemManager.service
          5.211s udisks2.service
          4.310s abrtd.service
          4.278s livesys.service
          4.087s bluetooth.service
          4.087s rtkit-daemon.service
          4.084s avahi-daemon.service
          4.003s rsyslog.service
          3.225s lvm2-pvscan@8:19.service
          2.857s systemd-udevd.service
          2.727s dracut-initqueue.service
          2.514s upower.service
          1.942s chronyd.service
          1.881s fedora-readonly.service
          1.764s gssproxy.service
          1.734s systemd-tmpfiles-setup-dev.service
          1.607s dmraid-activation.service
          1.395s systemd-vconsole-setup.service
          1.294s polkit.service
          1.244s systemd-fsck@dev-disk-by\x2duuid-002e9fa9\x2d59d3\x2d4ff1\x2db249\x2d3ab81dbcc18d.service
          1.089s colord.service
          1.068s systemd-tmpfiles-setup.service
          1.060s packagekit.service
           952ms auditd.service
           819ms fedora-import-state.service
           791ms systemd-rfkill.service
           791ms dnf-makecache.service
           671ms boot.mount
           649ms accounts-daemon.service
           586ms NetworkManager.service
           507ms cups.service
           473ms user@1000.service
           449ms wpa_supplicant.service
           385ms systemd-sysctl.service
           365ms systemd-udev-trigger.service
           283ms plymouth-read-write.service
           274ms home.mount
           254ms systemd-backlight@backlight:acpi_video0.service
           233ms systemd-remount-fs.service
           225ms systemd-fsck@dev-mapper-fedora\x2dhome.service
           206ms dev-hugepages.mount
           184ms systemd-fsck-root.service
           177ms systemd-journald.service
           174ms sys-kernel-debug.mount
           174ms nfs-config.service
           174ms dracut-pre-pivot.service
           171ms dev-mapper-fedora\x2dswap.swap
           168ms dev-mqueue.mount
           167ms initrd-parse-etc.service
           158ms dracut-cmdline.service
           157ms rpc-statd-notify.service
           154ms systemd-logind.service
           153ms systemd-user-sessions.service
           126ms kmod-static-nodes.service
           122ms dracut-shutdown.service
           110ms systemd-random-seed.service
            98ms plymouth-switch-root.service
            96ms var-lib-nfs-rpc_pipefs.mount
            87ms plymouth-quit-wait.service
            86ms plymouth-quit.service
            48ms dracut-pre-udev.service
            46ms sysroot.mount
            45ms systemd-update-utmp.service
            19ms plymouth-start.service
            19ms initrd-cleanup.service
            14ms livesys-late.service
            11ms initrd-udevadm-cleanup-db.service
             8ms systemd-update-utmp-runlevel.service
             7ms tmp.mount
             3ms sys-kernel-config.mount

Further, systemctl-failed command gives

0 loaded units listed. Pass --all to see loaded but inactive units, too.
To show all installed unit files use 'systemctl list-unit-files'.

Can someone please help me to reduce the boot time? either by disabling services from booting or by suggesting any hacks? I love fedora and i learnt many things these 5 days and would like to stick to fedora..

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2018-01-13 09:10:00 -0600

From the details you provide, I would wager the source of your problem is well described by: * WD hardisk 5400 rpm * 13.740s systemd-journal-flush.service * 10.613s lvm2-monitor.service

A 5400 RPM disk is as slow as it gets. The systemd-journal-flush.service is responsible for writing the contents of the system journal to persistent storage (i.e. your hard disk). The reason it executes at boot is to ensure that all of your boot messages are captured persistently early in the boot process (so that you can use those messages for troubleshooting if you experience crashes). Your boot is almost certainly slowed because the somewhat voluminous messages generated by the boot process take a long while to write to a slow 5400 RPM disk which is also bogged down with the task of loading your OS data into memory for the rest of your services to start.

Sadly, the best way to address this would be to get a new hard disk. If you purchase an SSD for your machine, you will be floored by how much improvement you notice. If you use the machine for little beyond standard office computing needs, that's the absolute best way to improve your current workstation - given what you've said about it, it's almost certainly a bottleneck for performance in everything you do.

In the interim, you could consider removing the '/var/log/journal' directory. Because Fedora, by default, deploys /etc/systemd/journald.conf with the 'Storage=auto' directive, the absence of the /var/log/journal directory will cause journald to switch over to storing log data in memory only (in the tmpfs virtual filesystem under /run/log/journal). The downside is that your system log will only be available in memory (so it will all clear out every time you reboot), but the upside will be that you no longer need to flush the journal to disk at boot, and that should shave off at least 14 seconds from your boot procedure.

But get an SSD if you can; should be a good investment given your hardware specs.

edit flag offensive delete link more

Comments

Thank you so much for the reply. as you mentioned, deleting /var/log/journal did have quite an impact on the boot time. boot time has reduced by 6s. Furthermore, As you mentioned, i am planning to get an ssd and then dual booting win10 and F27 from it.

Further, i Installed nvidia drivers yesterday, now instead of systemd-journal-flush, akmods.service is taking 11s. But it seems akmods is required by nvidia driver.

So finally, an SSD.

Thank you soo much for the patient reply. :-)

Silvermystv7 gravatar imageSilvermystv7 ( 2018-01-13 21:29:41 -0600 )edit

Hey, no worries; glad to help! Your computer will live a life you didn't know it was capable of living with an SSD.

bitwiseoperator gravatar imagebitwiseoperator ( 2018-01-14 04:25:17 -0600 )edit
0

answered 2018-01-13 02:50:07 -0600

wallyk gravatar image

I don't recommend disabling services just to speed up booting unless you will somehow not be using a full range of computer services. Bluetooth-less? WiFi-less? Networking? Fuse (ability to mount any kind of filesystem like NTFS). Yes, one could speed up the booting by selecting runlevel 1 (single user, no GUI), but then that is really only for system maintenance, not using Fedora.

Any particular reason for choosing KDE? How long does it take to boot Windows (and which version)?

I have F27 running Gnome and it boots in about 12 seconds, though this is from a SSD on an 8 core Lenovo Flex 5 with 16 GB. 12 seconds is also about what it takes booting F24 on a 10-year-old Lenovo R61 (2 cores) with 4 GB.

Maybe you twiddled with the installation or boot parameters? During the Fedora installation, did you choose any non-default options?

edit flag offensive delete link more

Comments

Thank you for the reply.

I went with kde since it resembles Windows the most. when booting into windows 10 the same system takes around 5 - 10 s. Also, I didnt change anything during the installation.

Since i got so used to getting into the desktop under 10seconds on windows i thought it could be done here as well by tweaking Kde.

From the output of systemd-analyze i was able to see that the actual boot-time is less than 7 seconds(If i am interpreting it correctly) and only during the userspace loading it takes longer.

Silvermystv7 gravatar imageSilvermystv7 ( 2018-01-13 04:51:16 -0600 )edit

So, I wanted to know if by disabling services which arent needed during boot time and by enabling then when needed after reaching the desktop, i could reduce the time i get into a useable desktop faster. Much like in windows where you disable startup items or services.

Silvermystv7 gravatar imageSilvermystv7 ( 2018-01-13 04:55:27 -0600 )edit

Question Tools

Stats

Asked: 2018-01-12 22:54:43 -0600

Seen: 2,000 times

Last updated: Jan 13 '18