Ask Your Question
1

How to configure XRDP on Fedora 27

asked 2017-12-30 09:50:58 -0600

Marc lml gravatar image

After installing XRDP by using dnf install xrdp and systemctl start xrdp I tried to make a connection. First it showed a black screen. Later it showed the following error message:

connecting to sesman ip 172.0.0.1 port 3350
sesman connect ok
sending login info to session manager, please wait...
login succesful for dispalay 10
VNC started connecting
VNC connecting to 127.0.0.1 5910
VNC tcp connected
VNC error - problem connecting
some problem

So basically it just won't work out of the box.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2017-12-30 10:05:55 -0600

Marc lml gravatar image

It turned out that additional configuration is needed. There are multiple ways to do this, but this works for me.

Make backups of original files

cp -f /etc/xrdp/xrdp.ini /etc/xrdp/xrdp.ini.org
cp -f /etc/xrdp/sesman.ini /etc/xrdp/sesman.ini.org

Use Xorg

sed -i "s/autorun=/autorun=Xorg/g" /etc/xrdp/xrdp.ini

Prevent the error: Listening socket is in wrong state, terminating listener

sed -i "0,/allow_channels=true/{s/allow_channels=true/allow_channels=false/}" /etc/xrdp/xrdp.ini

Start the correct session; ~/.Xinitrc is not needed

echo "PREFERRED=gnome-session" > /etc/sysconfig/desktop

Prevent the error: Could not acquire name on session bus

echo "unset DBUS_SESSION_BUS_ADDRESS; gnome-session" >> /etc/sysconfig/desktop
echo "allowed_users=anybody" > /etc/X11/Xwrapper.config

Xrdp disconnected when using the clipboard

sed -i "/param=96/ a param=-AcceptCutText=0\nparam=-SendCutText=0\nparam=-SendPrimary=0\nparam=-SetPrimary=0" /etc/xrdp/sesman.ini

Restart XRDP

systemctl restart xrdp

Sources:

https://github.com/neutrinolabs/xrdp/issues/755

https://mknowles.com.au/wordpress/2013/02/15/installing-xrdp-on-fedora-18-with-mate-desktop/

http://pkgs.fedoraproject.org/cgit/rpms/xrdp.git/tree/README.Fedora?h=f25&id=12a8dc25dd6df49335eb643c55e18abdb084b4d5

edit flag offensive delete link more

Comments

Thank you for posting how you fixed this!

Just spent many hours Googling on fixing the same problem on Fedora 29 and you're the first solution that worked.

MeatBunny gravatar imageMeatBunny ( 2018-11-09 12:22:04 -0600 )edit
0

answered 2019-01-08 07:14:41 -0600

Fixed the issue for me on Fedora 29, thanks a lot!

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2017-12-30 09:50:58 -0600

Seen: 3,520 times

Last updated: Dec 30 '17