Ask Your Question
0

Display resolution of 13.3″ 3200 × 1800 HiDPI

asked 2017-12-24 01:12:29 -0600

Cyber Linux gravatar image

updated 2017-12-24 07:10:53 -0600

Hi,

1) I got a new laptop with a Display resolution of 13.3″ 3200 × 1800 HiDPI. Now I tried to change the resolution in the grub, I could not see when switching to Alt+Ctrl+F2 terminal mode or boot-grub ( everything too small there)!

2) I am running under Xorg everything comes with (3:4) except the first one (16:9) when opening some apps, I couldn't see anything:(

How could I fix that?

xrandr output:
3200x1800 59.70+ 2048x1536 60.00
1920x1440 60.00
1856x1392 60.01
1792x1344 60.01
1600x1200 60.00
1400x1050 59.98
1280x1024 60.02
1280x960 60.00
1024x768 60.04 60.00
960x720 60.00
928x696 60.05
896x672 60.01
800x600 60.00 60.32 56.25
700x525 59.98
640x512 60.02
640x480 60.00 59.94
512x384 60.00
400x300 60.32 56.34
320x240 60.05
*

Thank you in advance

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
1

answered 2017-12-25 14:11:42 -0600

Cyber Linux gravatar image

updated 2017-12-25 14:19:00 -0600

(1) For the GRUB font size do:

sudo mkdir /boot/grub2/fonts
sudo grub2-mkfont -s 40 -o /boot/grub2/fonts/NotoSans-Bold.pf2 /usr/share/fonts/google-noto/NotoSans-Bold.ttf

*Feel free to change the font and size (see the list /usr/share/fonts)

(2) Add the FONT and TERMINAL OUTPUT in GRUB: /etc/default/grub

GRUB_FONT="/boot/grub2/fonts/NotoSans-Bold.pf2"
GRUB_TERMINAL_OUTPUT="gfxterm"

(3) Update the GRUB:

BIOS

sudo grub2-mkconfig -o /boot/grub2/grub.cfg

EFI:

sudo grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg

(4) For the TERMINAL mode( Alt+Ctrl+F2)

a) Install the terminus-fonts-console:

sudo dnf install terminus-fonts-console

b) Set the font for /usr/lib/kbd/consolefonts

sudo setfont Lat2-Terminus16

c) Add to /etc/vconsole.conf:

KEYMAP="us"
FONT="Lat2-Terminus16"

*Feel free to change the font (see the list /usr/lib/kbd/consolefonts)

d) Then, edit /usr/lib/systemd/system/systemd-vconsole-setup.service and add these lines:

After=sysinit.target
Before=shutdown.target

That's it :)

edit flag offensive delete link more

Comments

Great answer :). It's great when people figure out the issue themselves and post back.

abadrinath gravatar imageabadrinath ( 2017-12-25 16:57:53 -0600 )edit

self-learning = make issues then solve them. thank you and best

Cyber Linux gravatar imageCyber Linux ( 2017-12-25 19:39:29 -0600 )edit
0

answered 2017-12-24 07:53:07 -0600

scottro gravatar image

I have a page that talks about the yoga2, which uses HIDPI. http://srobb.net/yoga2.html

I boot into text mode and start X. Assuming the display is called eDP1 (sometimes eDP-1) you can open a terminal and do something like xrandr --ouput eDP1 --scale .7x.7 (I don't see the output line in your xrandr, didn't it say output eDP1 or similar?)

You can also in .Xdefaults (not sure where you would put it if you are booting into X), put

xft.dpi:192

The ArchLinux wiki has a page on hidpi https://wiki.archlinux.org/index.php/...

Also, at least on my yoga2, using the live workstation automatically scaled the screen correctly when it used Wayland.

edit flag offensive delete link more

Comments

Many thanks, please see my answer for the solution :)

Cyber Linux gravatar imageCyber Linux ( 2017-12-25 14:09:22 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2017-12-24 01:12:29 -0600

Seen: 772 times

Last updated: Dec 25 '17